VS:Get3DOrientation

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Get3DOrientation returns the 3D orientation of the referenced object.

If the object is mirrored, a reflection across the X-Y plane must be applied before rotating by the angles above in order to reproduce the object's orientation.

FUNCTION Get3DOrientation(
h :HANDLE;
VAR xRot :REAL;
VAR yRot :REAL;
VAR zRot :REAL;
VAR isMirroredXY :BOOLEAN) : BOOLEAN;
def vs.Get3DOrientation(h):
    return (BOOLEAN, xRot, yRot, zRot, isMirroredXY)

Parameters

h HANDLE Handle to 3D object.
xRot REAL Returns X rotation value.
yRot REAL Returns Y rotation value.
zRot REAL Returns Z rotation value.
isMirroredXY BOOLEAN Returns mirror status of object.

Return Value

Get3DOrientation returns TRUE if a valid 3D object was passed to the procedure.

Version

Availability: from VectorWorks8.0