VS:Get3DCntr

From Vectorworks Developer
Revision as of 13:15, 8 March 2016 by Patrick (talk | contribs) (Mentionded that the BoundingBox is used for center calculation.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Get3DCntr returns the three-dimensional center point of the referenced 3D object (BoundingBox).

PROCEDURE Get3DCntr(
h :HANDLE;
VAR pX,pY :REAL;
VAR zValue :REAL);
def vs.Get3DCntr(h):
    return (p, zValue)

Parameters

h HANDLE Handle to object.
p REAL Returns coordinates of object center point.
zValue REAL Returns elevation of object center point.

Example

Template:Get3DOrientation

Version

Availability: from All Versions