VS:Get3DCntr: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(Mentionded that the BoundingBox is used for center calculation.)
 
(One intermediate revision by one other user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure Get3DCntr returns the three-dimensional center point of the referenced 3D object.
Procedure Get3DCntr returns the three-dimensional center point of the referenced 3D object (BoundingBox).


</desc>
</desc>

Latest revision as of 13:15, 8 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Get3DCntr returns the three-dimensional center point of the referenced 3D object (BoundingBox).

PROCEDURE Get3DCntr(
h :HANDLE;
VAR pX,pY :REAL;
VAR zValue :REAL);
def vs.Get3DCntr(h):
    return (p, zValue)

Parameters

h HANDLE Handle to object.
p REAL Returns coordinates of object center point.
zValue REAL Returns elevation of object center point.

Example

Template:Get3DOrientation

Version

Availability: from All Versions