VS:Get2DPt

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the location of the specified vertex of a referenced object.

PROCEDURE Get2DPt(
obj :HANDLE;
index :INTEGER;
VAR locX,locY :REAL);
def vs.Get2DPt(obj, index):
    return loc

Parameters

obj HANDLE Handle to object.
index INTEGER Index of vertex to be queried.
loc REAL Coordinates of 2D vertex location.

Remarks

Used with bounding box objects without vertexes (groups...), the routine doesn't throw error and always returns the coordinates of the center, independently of the passed vertex index.

(RGM Feb 2006): This will generally return the center of an object. Use GetSymLoc if you want eg. the 'point' of a Point PIO.

Version

Availability: from VectorWorks 8.5