VS:Get2DComponentGroup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(fix table)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Gets the specified 2D component group of a symbol definition or plug-in object or NULL if the group does not exist.                                                                                                                                                                           Table - 2D components<BR>
Gets the specified 2D component group of a symbol definition or plug-in object or NULL if the group does not exist.
2D component Constant<BR>
 
Not Set 0<BR>
 
Top 1<BR>
''Table - 2D components''
Bottom 2<BR>
{| class = "wikitable_c"
Top and Bottom Cut                 3<BR>
! Constant !! 2D component
Front 4<BR>
|-
Back 5<BR>
| 0 || Not Set
Front and Back Cut                 6<BR>
|-
Left 7<BR>
| 1 || Top
Right 8<BR>
|-
Left and Right Cut                 9  <BR>
| 2 || Bottom
|-
| 3 || Top and Bottom Cut
|-
| 4 || Front
|-
| 5 || Back
|-
| 6 || Front and Back Cut
|-
| 7 || Left
|-
| 8 || Right
|-
| 9  || Left and Right Cut  
|}
</desc>
</desc>



Latest revision as of 05:47, 14 February 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified 2D component group of a symbol definition or plug-in object or NULL if the group does not exist.


Table - 2D components

Constant 2D component
0 Not Set
1 Top
2 Bottom
3 Top and Bottom Cut
4 Front
5 Back
6 Front and Back Cut
7 Left
8 Right
9 Left and Right Cut
FUNCTION Get2DComponentGroup(
objectHandle :HANDLE;
component :INTEGER) : HANDLE;
def vs.Get2DComponentGroup(objectHandle, component):
    return HANDLE

Parameters

objectHandle HANDLE Handle to the object.
component INTEGER 2D component.

Return Value

Returns a HANDLE to the specified 2D component group.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Set2DComponentGroup | VS:SetTopPlan2DComp | VS:GetTopPlan2DComp

VS Functions:

[[VS:Set2DComponentGroup]] | [[VS:SetTopPlan2DComp]]

| [[VS:GetTopPlan2DComp]]