VS:Get2DComponentGroup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 22:36, 12 September 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified 2D component group of a symbol definition or plug-in object or NULL if the group does not exist. Table - 2D components

2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9

FUNCTION Get2DComponentGroup(
objectHandle :HANDLE;
component :INTEGER) : HANDLE;
def vs.Get2DComponentGroup(objectHandle, component):
    return HANDLE

Parameters

objectHandle HANDLE Handle to the object.
component INTEGER 2D component.

Return Value

Returns a HANDLE to the specified 2D component group.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Set2DComponentGroup | VS:SetTopPlan2DComp | VS:GetTopPlan2DComp

VS Functions:

[[VS:Set2DComponentGroup]] | [[VS:SetTopPlan2DComp]]

| [[VS:GetTopPlan2DComp]]