VS:Generate2DFrom3DComp

From Vectorworks Developer
Revision as of 22:36, 12 September 2018 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Generates the specified 2D component of a symbol definition or plug-in object from the 3D component.

The resulting graphics will be similar to converting the 3D component to lines from a view corresponding to the 2D component view.
3D objects visible in the specified detail level will be used to generate the 2D component.

                Table - 2D components

2D component Constant
Not Set 0
Top 1
Bottom 2
Top and Bottom Cut 3
Front 4
Back 5
Front and Back Cut 6
Left 7
Right 8
Left and Right Cut 9

                                                                 
Table - Available Render Modes

Render Mode Constant
Wireframe 0
Hidden Line 6
Dashed Hidden Line 7

Table - Detail levels
Detail level Constant
Low 1
Medium 2
High 4
All 7

FUNCTION Generate2DFrom3DComp(
objectHandle :HANDLE;
component :INTEGER;
renderMode :INTEGER;
levelOfDetail :INTEGER) : BOOLEAN;
def vs.Generate2DFrom3DComp(objectHandle, component, renderMode, levelOfDetail):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle of a symbol or plug-in object.
component INTEGER 2D component.
renderMode INTEGER Render mode.
levelOfDetail INTEGER Detail level. 3D objects visible in this detail level will be used to generate 2D component.

Return Value

TRUE if the operatuion succeeded.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Get2DComponentGroup | VS:Set2DComponentGroup

VS Functions:

[[VS:Get2DComponentGroup]]

| [[VS:Set2DComponentGroup]]