VS:Generate2DFrom3DComp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(wikify lost tables)
(use wiki table_c)
Line 10: Line 10:
3D objects visible in the specified detail level will be used to generate the 2D component.
3D objects visible in the specified detail level will be used to generate the 2D component.


{| class="wikitable"
{| class = "wikitable_c"
|+ Table - 2D components
|+ '''Table - 2D components'''
! 2D component !! Constant
! 2D component !! Constant
|-
|-
| Not Set || 0
| 0 || Not Set
|-
|-
| Top || 1
| 1 || Top
|-
|-
| Bottom || 2
| 2 || Bottom
|-
|-
| Top and Bottom Cut || 3
| 3 || Top and Bottom Cut  
|-
|-
| Front || 4
| 4 || Front
|-
|-
| Back || 5
| 5 || Back
|-
|-
| Front and Back Cut || 6
| 6 || Front and Back Cut  
|-
|-
| Left || 7
| 7 || Left
|-
|-
| Right || 8
| 8 || Right
|-
|-
| Left and Right Cut || 9 
| 9  || Left and Right Cut  
|}  
|}  


{| class="wikitable"     
 
|+ Table - Available Render Modes
{| class = "wikitable_c"     
|+ '''Table - Available Render Modes'''
! Render Mode !! Constant  
! Render Mode !! Constant  
|-
|-
| Wireframe || 0
| 0 || Wireframe
|-
|-
| Hidden Line || 6
| 6 || Hidden Line  
|-
|-
| Dashed Hidden Line || 7
| 7  || Dashed Hidden Line  
|}
|}


{| class="wikitable"
 
|+ Table - Detail levels
{| class = "wikitable_c"
|+ '''Table - Detail levels'''
! Detail level !! Constant
! Detail level !! Constant
|-
|-
| Low || 1
| 1 || Low
|-
|-
| Medium || 2
| 2 || Medium
|-
|-
| High || 4
| 4 || High
|-
|-
| All || 7
| 7 || All
|}
|}
</desc>
</desc>



Revision as of 05:36, 14 February 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Generates the specified 2D component of a symbol definition or plug-in object from the 3D component.

The resulting graphics will be similar to converting the 3D component to lines from a view corresponding to the 2D component view.
3D objects visible in the specified detail level will be used to generate the 2D component.

Table - 2D components
2D component Constant
0 Not Set
1 Top
2 Bottom
3 Top and Bottom Cut
4 Front
5 Back
6 Front and Back Cut
7 Left
8 Right
9 Left and Right Cut


Table - Available Render Modes
Render Mode Constant
0 Wireframe
6 Hidden Line
7 Dashed Hidden Line


Table - Detail levels
Detail level Constant
1 Low
2 Medium
4 High
7 All
FUNCTION Generate2DFrom3DComp(
objectHandle :HANDLE;
component :INTEGER;
renderMode :INTEGER;
levelOfDetail :INTEGER) : BOOLEAN;
def vs.Generate2DFrom3DComp(objectHandle, component, renderMode, levelOfDetail):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle of a symbol or plug-in object.
component INTEGER 2D component.
renderMode INTEGER Render mode.
levelOfDetail INTEGER Detail level. 3D objects visible in this detail level will be used to generate 2D component.

Return Value

TRUE if the operatuion succeeded.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Get2DComponentGroup | VS:Set2DComponentGroup

VS Functions:

[[VS:Get2DComponentGroup]]

| [[VS:Set2DComponentGroup]]