VS:Generate2DFrom3DComp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (fix typo)
 
(4 intermediate revisions by 2 users not shown)
Line 8: Line 8:
Generates the specified 2D component of a symbol definition or plug-in object from the 3D component.<BR>
Generates the specified 2D component of a symbol definition or plug-in object from the 3D component.<BR>
The resulting graphics will be similar to converting the 3D component to lines from a view corresponding to the 2D component view. <BR>
The resulting graphics will be similar to converting the 3D component to lines from a view corresponding to the 2D component view. <BR>
3D objects visible in the specified detail level will be used to generate the 2D component.<BR>
3D objects visible in the specified detail level will be used to generate the 2D component.
<BR>
 
                Table - 2D components<BR>
 
2D component Constant<BR>
''Table - 2D components''
Not Set 0<BR>
{| class = "wikitable_c"
Top 1<BR>
! Constant !! 2D component
Bottom 2<BR>
|-
Top and Bottom Cut 3<BR>
| 0 || Not Set
Front 4<BR>
|-
Back 5<BR>
| 1 || Top  
Front and Back Cut                 6<BR>
|-
Left 7<BR>
| 2 || Bottom  
Right 8<BR>
|-
Left and Right Cut                 9    <BR>
| 3 || Top and Bottom Cut  
                                                                  <BR>
|-
                Table - Available Render Modes<BR>
| 4 || Front  
Render Mode                                         Constant <BR>
|-
Wireframe 0 <BR>
| 5 || Back  
Hidden Line 6 <BR>
|-
Dashed Hidden Line 7 <BR>
| 6 || Front and Back Cut  
<BR>
|-
Table - Detail levels<BR>
| 7 || Left  
Detail level Constant<BR>
|-
Low 1<BR>
| 8 || Right  
Medium 2<BR>
|-
High 4<BR>
| 9  || Left and Right Cut  
All 7</desc>
|}
 
 
''Table - Available Render Modes''
{| class = "wikitable_c"   
! Constant !! Render Mode
|-
| 0 || Wireframe  
|-
| 6 || Hidden Line  
|-
| 7  || Dashed Hidden Line  
|}
 
 
''Table - Detail levels''
{| class = "wikitable_c"
! Constant !! Detail level
|-
| 1 || Low  
|-
| 2 || Medium  
|-
| 4 || High  
|-
| 7 || All  
|}
 
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 75: Line 103:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
TRUE if the operatuion succeeded.</return>
TRUE if the operation succeeded.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:11, 15 February 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Generates the specified 2D component of a symbol definition or plug-in object from the 3D component.

The resulting graphics will be similar to converting the 3D component to lines from a view corresponding to the 2D component view.
3D objects visible in the specified detail level will be used to generate the 2D component.


Table - 2D components

Constant 2D component
0 Not Set
1 Top
2 Bottom
3 Top and Bottom Cut
4 Front
5 Back
6 Front and Back Cut
7 Left
8 Right
9 Left and Right Cut


Table - Available Render Modes

Constant Render Mode
0 Wireframe
6 Hidden Line
7 Dashed Hidden Line


Table - Detail levels

Constant Detail level
1 Low
2 Medium
4 High
7 All
FUNCTION Generate2DFrom3DComp(
objectHandle :HANDLE;
component :INTEGER;
renderMode :INTEGER;
levelOfDetail :INTEGER) : BOOLEAN;
def vs.Generate2DFrom3DComp(objectHandle, component, renderMode, levelOfDetail):
    return BOOLEAN

Parameters

objectHandle HANDLE Handle of a symbol or plug-in object.
component INTEGER 2D component.
renderMode INTEGER Render mode.
levelOfDetail INTEGER Detail level. 3D objects visible in this detail level will be used to generate 2D component.

Return Value

TRUE if the operation succeeded.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:Get2DComponentGroup | VS:Set2DComponentGroup

VS Functions:

[[VS:Get2DComponentGroup]]

| [[VS:Set2DComponentGroup]]