VS:Function Reference Appendix F: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "== Appendix F - Preference Selectors == === Application Preference Selectors === {| class="wikitable" !Preference !! Selector !! Preference Value !! Function |- |Click-Drag ...")
 
Line 355: Line 355:
|-
|-
| ||  || 2 (InternalStatesEvent) || “
| ||  || 2 (InternalStatesEvent) || “
|}
=== On-Demand Menu Selectors ===
{| class="wikitable"
!Preference !! Selector !! Preference Data Type !! Function
|-
|Use ODM|| 6900 || TRUE or FALSE || [[VS:GetPref]]
|-
|Show ODM After Mouse Idle|| 6901 || TRUE or FALSE || [[VS:GetPref]]
|-
|ODM Mouse Idle Timer || 6902 || INTEGER || [[VS:GetPrefInt]]
|-
|Show ODM with Spacebar || 6903 || TRUE or FALSE || [[VS:GetPref]]
|-
|Show ODM with Middle Mouse Button || 6904 || TRUE or FALSE || [[VS:GetPref]]
|-
|Initialize ODM Layout || 6905 || INTEGER || [[VS:GetPrefInt]]
|-
| || || 0 (Icon Hint) || [[VS:GetPrefInt]]
|-
| || || 1 (Text Hint) || [[VS:GetPrefInt]]
|-
| || || 2 (Icon and Text Hint) || [[VS:GetPrefInt]]
|-
| || || 3 (Full View) || [[VS:GetPrefInt]]
|-
|Section ODM Parameters || 6906 || Integer || [[VS:GetPrefInt]]
|-
| || || 0 (Section ID) || [[VS:GetPrefInt]]
|-
| || || 1 (Section Type) || [[VS:GetPrefInt]]
|-
| || || 0 (None) || [[VS:GetPrefInt]]
|-
| || || 1 (Tool Modes) || [[VS:GetPrefInt]]
|-
| || || 2 (Snapping Bar) || [[VS:GetPrefInt]]
|-
| || || 3 (Recent Tools) || [[VS:GetPrefInt]]
|-
| || || 4 (Standard Views) || [[VS:GetPrefInt]]
|-
| || || 5 (Tool Sets) || [[VS:GetPrefInt]]
|-
| || 2 (Quadrant Position) || ||
|-
| || || 0 (Top Left) || [[VS:GetPrefInt]]
|-
| || || 1 (Top Right) || [[VS:GetPrefInt]]
|-
| || || 2 (Bottom Left) || [[VS:GetPrefInt]]
|-
| || || 3 (Bottom Right) || [[VS:GetPrefInt]]
|-
| || 3 (Tool Set ID) || ||
|-
|Show ODM Search Filters || 7000 || True or False || [[VS:GetPref]]
|-
|Show ODM Command Context || 7001 || True or False || [[VS:GetPref]]
|-
| || || 4 (Tool Set Name)
|}
|}



Revision as of 20:41, 15 January 2021

Appendix F - Preference Selectors

Application Preference Selectors

Preference Selector Preference Value Function
Click-Drag Mode 0 TRUE or FALSE VS:GetPref
Offset Duplicates 1 TRUE or FALSE VS:GetPref
Full Screen Cursor 2 TRUE or FALSE VS:GetPref
Show Screen Hints 3 TRUE or FALSE VS:GetPref
Floating Datum 4 TRUE or FALSE VS:GetPref
Snap To Loci 5 TRUE or FALSE VS:GetPref
Show Rulers 6 TRUE or FALSE VS:GetPref
Show Scroll Bars 7 TRUE or FALSE VS:GetPref
No Fill Behind Text 8 TRUE or FALSE VS:GetPref
Zoom Line Thickness 9 TRUE or FALSE VS:GetPref
Black and White Only 10 TRUE or FALSE VS:GetPref
Use Layer Colors 11 TRUE or FALSE VS:GetPref
Log Time in Program 12 TRUE or FALSE VS:GetPref
Adjust Flipped Text 13 TRUE or FALSE VS:GetPref
Show Other Objects While In Group 14 TRUE or FALSE VS:GetPref
Show 3D Axis Labels 15 TRUE or FALSE VS:GetPref
Use Black Background 16 TRUE or FALSE VS:GetPref
Use Eight Selection Handles 17 TRUE or FALSE VS:GetPref
Use Sound 18 TRUE or FALSE VS:GetPref
Issue Undo Warnings 19 TRUE or FALSE VS:GetPref
Opaque SmartCursor 20 TRUE or FALSE VS:GetPref
Stop VectorScript on Warnings 21 TRUE or FALSE VS:GetPref
Left Palette Margin 22 TRUE or FALSE VS:GetPref
Right Palette Margin 23 TRUE or FALSE VS:GetPref
Use Save Reminder 24 TRUE or FALSE VS:GetPref
Show Parametric Constraints 25 TRUE or FALSE VS:GetPref
Display Minor Alerts on Mode Bar 27 TRUE or FALSE VS:GetPref
Associate Dimensions 28 TRUE or FALSE VS:GetPref
Spell Check Capitalized Words 29 TRUE or FALSE VS:GetPref
Spell Check Words in ALL CAPS 30 TRUE or FALSE VS:GetPref
Spell Check Mixed Case Words 31 TRUE or FALSE VS:GetPref
Spell Check Words With Numbers 32 TRUE or FALSE VS:GetPref
Auto Join Walls 33 TRUE or FALSE VS:GetPref
Show Page Breaks 34 TRUE or FALSE VS:GetPref
Show Grid 35 TRUE or FALSE VS:GetPref
Print Grid 36 TRUE or FALSE VS:GetPref
Snap To Grid 37 TRUE or FALSE VS:GetPref
Snap To Object 38 TRUE or FALSE VS:GetPref
Save By Time 39 TRUE or FALSE VS:GetPref
Save Confirm 40 TRUE or FALSE VS:GetPref
Save To Backup 41 TRUE or FALSE VS:GetPref
Palette Docking 43 TRUE or FALSE VS:GetPref
Create Dimensions in Dimension Class 44 TRUE or FALSE VS:GetPref
Accelerated 2D Navigation 45 TRUE or FALSE VS:GetPref
Use Vector Caching 46 TRUE or FALSE VS:GetPref
Sketch Hidden Line 47 TRUE or FALSE VS:GetPref
Snap to Edge Points 48 TRUE or FALSE VS:GetPref
Show Page Boundary 49 TRUE or FALSE VS:GetPref
Display Default Content 130 TRUE or FALSE VS:GetPref
Dimension Slash Thickness Unit 50 3 = points, 2 = mils, 1 = mm VS:GetPrefInt
3D Rotation Responsiveness 52 1(detailed)..5(responsive) VS:GetPrefInt
Custom Constraint Angle 53 REAL (degrees) VS:GetPrefReal
Snap Radius 54 INTEGER value VS:GetPrefInt
2D Conversion Resolution 55 INTEGER value VS:GetPrefInt
3D Conversion Resolution 56 INTEGER value VS:GetPrefInt
Current Document Text Size 57 REAL VS:GetPrefReal
Current Document Text Style 58 0 (Plain) VS:GetPrefInt
1 (Bold) "
2 (Italic) "
4 (Underline) "
8 (Outline [Mac only]) "
16 (Shadow [Mac only]) "
Current Document Text Justification 82 1 (Left) VS:GetPrefInt
2 (Center) "
3 (Right) "
Current Document Text Vertical Alignment 83 1 (TopBox) VS:GetPrefInt
2 (TopBaseline) "
3 (CenterBox) "
4 (BottomBaseline) "
5 (BottomBox) "
Current Document Text Vertical Spacing 84 0 (Custom Leading) VS:GetPrefInt
2 (Single) "
3 (Three Halves) "
4 (Double) "
Current Document Text Vertical Spacing Custom Value 85 REAL VS:GetPrefReal
Maximum Number of Undos 59 INTEGER VS:GetPrefInt
Undo View Changes 26 1 (never) VS:GetPrefInt
2 (combine all) "
3 (combine similar) "
4 (combine none) "
Save Interval 60 no. of minutes VS:GetPrefInt
Display Light Objects 61 0(always) VS:GetPrefInt
1(wireframe) "
2(never) "
Display 3D Loci Objects 91 0(always) VS:GetPrefInt
1(wireframe)
2(never)
Retain QuickDraw 3D Model 62 1(never)...5(always) VS:GetPrefInt
Rotated Text Display 63 0(box) VS:GetPrefInt
1(normal) "
2(high) "
Bitmap Display 64 0(box) VS:GetPrefInt
1(low res) "
2(hi res) "
Dimension Slash Thickness 65 INTEGER value (mils) VS:GetPrefInt
Hidden Line Dash Style 66 INTEGER selector VS:GetPrefInt
Hidden Line Shading 67 1(dark)...4(light) VS:GetPrefInt
Grid X 78 REAL VS:GetPrefReal
Grid Y 79 REAL VS:GetPrefReal
Page Origin X 80 REAL (current units) VS:GetPrefReal
Page Origin Y 81 REAL (current units) VS:GetPrefReal
Page Scaling Factor 70 REAL VS:GetPrefReal
Dimension Standard 71 1 (Arch) VS:GetPrefInt
2 (ASME) "
3 (BSI) "
4 (DIN) "
5 (ISO) "
6 (JIS) "
7 (SIA) "
8 (ASME Dual Side-by-Side) "
9 (ASME Dual Stacked) "
Defacet Angle 72 REAL (0-90) VS:GetPrefReal
Grid Angle 73 REAL VS:GetPrefReal
Move Objects on Grid Keys 74 1 (arrow) VS:GetPrefInt
2 (cmd+arrow) "
3 (shift+arrow) "
4 (shift+cmd+arrow) "
Nudge Objects Keys 75 1-4 (see above) VS:GetPrefInt
Pan Drawing Keys 76 1-4 (see above) VS:GetPrefInt
Switch Active Layer/Class Keys 77 1-4 (see above) VS:GetPrefInt
Default Compression 86 1 = JPEG, 2 = PNG VS:GetPrefInt
Line Weight Array Count 87 INTEGER VS:GetPrefInt
Sound Volume 88 INTEGER VS:GetPrefInt
Custom Move Distance 89 REAL VS:GetPrefReal
Plan Rotation 92 TRUE or FALSE VS:GetPref
Plan Rotation Angle 93 REAL (read-only) VS:GetPrefReal
Stack Layers 94 TRUE or FALSE VS:GetPref
Stack Layers Create 2D Objects 95 TRUE or FALSE VS:GetPref
Stack Layers Ignore Other Scales 96 TRUE or FALSE VS:GetPref
Stack Layers Restore Views 97 TRUE or FALSE VS:GetPref
Use Open MP Multithreading 98 0 (no) VS:GetPrefInt
1 (yes) "
2 (partial) "
Stack Layers Center View 99 TRUE or FALSE VS:GetPref
Text Font Name 100 STRING VS:GetPrefString
Stack Layers Show Page Boundary 101 TRUE or FALSE VS:GetPref
Stack Layers Only Active Layer 2D Objects 102 TRUE or FALSE VS:GetPref
Angular Precision 120 INTEGER VS:GetPrefInt
Angular Unit 121 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Resetting Plugin-ins During File Read 129 TRUE or FALSE VS:GetPref
Display Default Content 130 TRUE or FALSE VS:GetPref
Auto File Extensions On Mac 131 TRUE or FALSE VS:GetPref
Use Advanced Imaging 132 TRUE or FALSE VS:GetPref
Use Anti Aliasing 133 TRUE or FALSE VS:GetPref
Auto Associate Dims 134 TRUE or FALSE VS:GetPref
Mouse Wheel Zoom 135 TRUE or FALSE VS:GetPref
Use Custom Move Distance 136 TRUE or FALSE VS:GetPref
Print Switch Binary 137 TRUE or FALSE VS:GetPref
Unit1 Dim Fraction Display Style 190 0 (regular style) VS:GetPrefInt
1 (diagonal style)
2 (horizontal style)
DXF Add Prefix To DXF Layers 328 TRUE or FALSE VS:GetPref
DXF Prefix To DXF Edit 329 STRING value VS:GetPrefString
DXF External Refs Handling 330 0 (Bind External Refs) VS:GetPrefInt
1 (Ignore External Refs)
2 (Create VW Refs)
3 (Use Layer Import)
DXF ADT Objects 2D View 331 TRUE or FALSE VS:GetPref
Use Framed Highlighting 410 TRUE or FALSE VS:GetPref
Smart Cursor Show Interactive Segment 411 TRUE or FALSE VS:GetPref
Snap To Tool Snap Geometry Only 460 TRUE or FALSE VS:GetPref
whether to coordinate sheet and drawing numbers for various items 544 TRUE or FALSE VS:GetPref
Auto Save To Custom Location 552 TRUE or FALSE VS:GetPref
Autosave Custom Location 554 STRING value VS:GetPrefString
Keep Backups By Number Value 555 TRUE or FALSE VS:GetPref
Center View 558 TRUE or FALSE VS:GetPref
Release Version Integer 570 SHORT - The release version integer defaults to 0 VS:GetPrefInt
get/set the insertion mode of the symbol tool 580 SHORT VS:GetPrefInt
get/set the wall insertion mode of the symbol tool 581 SHORT VS:GetPrefInt
get/set the alignment mode of the symbol tool 582 SHORT VS:GetPrefInt
Parametric Enable State Eventing 590 0 (NoStateEvents) VS:GetPrefInt
1 (ResetStatesEvent)
2 (InternalStatesEvent)

On-Demand Menu Selectors

Preference Selector Preference Data Type Function
Use ODM 6900 TRUE or FALSE VS:GetPref
Show ODM After Mouse Idle 6901 TRUE or FALSE VS:GetPref
ODM Mouse Idle Timer 6902 INTEGER VS:GetPrefInt
Show ODM with Spacebar 6903 TRUE or FALSE VS:GetPref
Show ODM with Middle Mouse Button 6904 TRUE or FALSE VS:GetPref
Initialize ODM Layout 6905 INTEGER VS:GetPrefInt
0 (Icon Hint) VS:GetPrefInt
1 (Text Hint) VS:GetPrefInt
2 (Icon and Text Hint) VS:GetPrefInt
3 (Full View) VS:GetPrefInt
Section ODM Parameters 6906 Integer VS:GetPrefInt
0 (Section ID) VS:GetPrefInt
1 (Section Type) VS:GetPrefInt
0 (None) VS:GetPrefInt
1 (Tool Modes) VS:GetPrefInt
2 (Snapping Bar) VS:GetPrefInt
3 (Recent Tools) VS:GetPrefInt
4 (Standard Views) VS:GetPrefInt
5 (Tool Sets) VS:GetPrefInt
2 (Quadrant Position)
0 (Top Left) VS:GetPrefInt
1 (Top Right) VS:GetPrefInt
2 (Bottom Left) VS:GetPrefInt
3 (Bottom Right) VS:GetPrefInt
3 (Tool Set ID)
Show ODM Search Filters 7000 True or False VS:GetPref
Show ODM Command Context 7001 True or False VS:GetPref
4 (Tool Set Name)

Primary Units Selectors

Preference Selector Preference Data Type Function
Unit Fraction 150 REAL value VS:GetPrefReal
Units Per Inch 152 REAL value VS:GetPrefReal
Unit Style Name 153 STRING value VS:GetPrefString
Unit Mark 154 STRING value VS:GetPrefString
Sunit Mark 155 STRING value VS:GetPrefString
Sunit Divider 156 STRING value VS:GetPrefString
Smultiplier 157 INTEGER value VS:GetPrefInt
Square Unit Mark 158 STRING value VS:GetPrefString
Square Unit Divisor 159 LONGINT VS:GetPrefLongInt
Cube Unit Mark 160 STRING value VS:GetPrefString
Cube Unit Divisor 161 LONGINT VS:GetPrefLongInt
Display Fraction 162 LONGINT value VS:GetPrefLongInt
Show Unit Mark 163 TRUE or FALSE VS:GetPref
Display Leading Zero 164 TRUE or FALSE VS:GetPref
Display Trailing Zeroes 165 TRUE or FALSE VS:GetPref
Use Minimum Units 166 TRUE or FALSE VS:GetPref
Use Custom Units 167 TRUE or FALSE VS:GetPref
Show Decimals as Fractions 168 TRUE or FALSE VS:GetPref
Dimension Precision 169 LONGINT value VS:GetPrefLongInt
Predefined Units Style 170 1 (Feet & Inches) VS:GetPrefInt
2 (Inches)
3 (Feet)
4 (Yards)
5 (Miles)
6 (Microns)
7 (Millimeters)
8 (Centimeters)
9 (Meters)
10 (Kilometers)
11 (Degrees – Landmark & Azimuth only)
Fractional Display Precision 171 LONGINT value VS:GetPrefLongInt
Fractional Dimension Precision 172 LONGINT value VS:GetPrefLongInt
Metric Unit Flag 173 TRUE or FALSE VS:GetPref
Angular Unit 174 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Round Fraction to Decimal 175 TRUE or FALSE VS:GetPref
Area Units Per Square Inch 176 REAL value VS:GetPrefReal
Area Unit Name 177 STRING value VS:GetPrefString
Area Unit Mark 178 STRING value VS:GetPrefString
Area Precision 179 LONGINT value VS:GetPrefLongInt
Volume Units Per Cubic Inch 180 REAL value VS:GetPrefReal
Volume Unit Name 181 STRING value VS:GetPrefString
Volume Unit Mark 182 STRING value VS:GetPrefString
Volume Precision 183 LONGINT value VS:GetPrefLongInt
Use Custom Area Units 184 TRUE or FALSE VS:GetPref
Use Custom Volume Units 185 TRUE or FALSE VS:GetPref
Area Unit Fraction 186 REAL value VS:GetPrefReal
Volume Unit Fraction 187 REAL value VS:GetPrefReal
Display Rounding Base 188 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)
Dimension Rounding Base 189 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)
Dimension Rounding Base 190 0 (regular style) VS:GetPrefInt
1 (diagonal style)
2 (horizontal style)

Secondary Units Selectors

Preference Selector Preference Data Type Function
Unit Fraction 200 REAL value VS:GetPrefReal
Units Per Inch 202 REAL value VS:GetPrefReal
Unit Style Name 203 64 character STRING VS:GetPrefString
Unit Mark 204 STRING value VS:GetPrefString
Sunit Mark 205 STRING value VS:GetPrefString
Sunit Divider 206 STRING value VS:GetPrefString
Smultiplier 207 INTEGER value VS:GetPrefInt
Square Unit Mark 208 STRING value VS:GetPrefString
Square Unit Divisor 209 LONGINT VS:GetPrefLongInt
Cube Unit Mark 210 STRING value VS:GetPrefString
Cube Unit Divisor 211 LONGINT value VS:GetPrefLongInt
Display Fraction 212 LONGINT value VS:GetPrefLongInt
Show Unit Mark 213 TRUE or FALSE VS:GetPref
Display Leading Zero 214 TRUE or FALSE VS:GetPref
Display Trailing Zeroes 215 TRUE or FALSE VS:GetPref
Use Minimum Units 216 TRUE or FALSE VS:GetPref
Use Custom Units 217 TRUE or FALSE VS:GetPref
Show Decimals as Fractions 218 TRUE or FALSE VS:GetPref
Dimension Precision 219 LONGINT value VS:GetPrefLongInt
Predefined Units Style 220 1 (Feet & Inches) VS:GetPrefInt
2 (Inches)
3 (Feet)
4 (Yards)
5 (Miles)
6 (Microns)
7 (Millimeters)
8 (Centimeters)
9 (Meters)
10 (Kilometers)
11 (Degrees – Landmark & Azimuth only)
Fractional Display Precision 221 LONGINT value VS:GetPrefLongInt
Fractional Dimension Precision 222 LONGINT value VS:GetPrefLongInt
Metric Unit Flag 223 TRUE or FALSE VS:GetPref
Angular Unit 224 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Round Fraction to Decimal 225 TRUE or FALSE VS:GetPref
Dimension Rounding Base 226 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)

DXF Preference Selectors

Preference Selector Preference Data Type Function
Auto Units 300 TRUE or FALSE VS:GetPref
Units 301 INTEGER VS:GetPrefInt
DXF Units Per Inch 302 REAL VS:GetPrefReal
Auto Model Space Scale 303 TRUE or FALSE VS:GetPref
Model Space Scale 304 REAL VS:GetPrefReal
2D 3D Import Handling 305 INTEGER VS:GetPrefInt
Map Layers to Classes 306 TRUE or FALSE VS:GetPref
Convert Mlines to Walls 307 TRUE or FALSE VS:GetPref
Convert Rays and Xlines 308 TRUE or FALSE VS:GetPref
Scale Dash Lengths 309 TRUE or FALSE VS:GetPref
Dash Length Scale 310 REAL VS:GetPrefReal
Auto Block Attribute Handling 311 TRUE or FALSE VS:GetPref
Block Attribute Handling 312 INTEGER VS:GetPrefInt
Auto Point Handling 313 TRUE or FALSE VS:GetPref
Convert Points to Loci 314 TRUE or FALSE VS:GetPref
Point Symbols are Guides 315 TRUE or FALSE VS:GetPref
Map Colors to Line Weights 316 TRUE or FALSE VS:GetPref
Set Line Colors Black 317 TRUE or FALSE VS:GetPref
Paper Space Units 318 INTEGER VS:GetPrefInt
Auto Scale Dash Lengths 319 TRUE or FALSE VS:GetPref
Group Record Fields 320 TRUE or FALSE VS:GetPref
Auto Line Weight Handling 321 TRUE or FALSE VS:GetPref
Convert Dimensions To Groups 322 TRUE or FALSE VS:GetPref
Rays and Lines To Guides 323 TRUE or FALSE VS:GetPref
Auto Center After Import 324 TRUE or FALSE VS:GetPref
Center After Import 325 TRUE or FALSE VS:GetPref
Use World Origin 326 TRUE or FALSE VS:GetPref
Set Vectorworks Units To Match 327 TRUE or FALSE VS:GetPref
Add Prefix To DXF Layers 328 TRUE or FALSE VS:GetPref
Prefix To DXF Edit 329 STRING value VS:GetPrefString
External Refs Handling 330 0 (bind external refs) VS:GetPrefInt
1 (ignore external refs) "
2 (create VW refs) "
3 (use layer import) "
ADT Objects 2D View 331 TRUE or FALSE VS:GetPref

Gradient and Image Fill Preference Selectors

Preference Selector Preference Data Type Function
Default Gradient Fill 508 LONGINT VS:GetPrefLongInt
Default Gradient Fill Angle 512 REAL VS:GetPrefReal
Default Gradient Fill Repeat 513 TRUE or FALSE VS:GetPref
Default Gradient Fill Geometric Type 515 INTEGER VS:GetPrefInt
Default Gradient Fill Mirror 516 TRUE or FALSE VS:GetPref
Default Image Fill Maintain Aspect Ratio 517 TRUE or FALSE VS:GetPref
Default Image Fill 518 LONGINT VS:GetPrefLongInt
Default Image Fill Angle 523 REAL VS:GetPrefReal
Default Image Fill Repeat 524 TRUE or FALSE VS:GetPref
Default Image Fill Mirror 526 TRUE or FALSE VS:GetPref
Default Image Fill Flip 527 TRUE or FALSE VS:GetPref
Default Image Fill I-Length 532 REAL (current units) VS:GetPrefReal
Default Image Fill J-Length 533 REAL (current units) VS:GetPrefReal
Default Fill Style 528 LONGINT VS:GetPrefLongInt
Default Fill Type 529 INTEGER VS:GetPrefInt
Default Hatch Fill 530 LONGINT VS:GetPrefLongInt

Misc. Preference Selectors

Preference Selector Preference Data Type Function
RenderWorks Enabled 240 TRUE or FALSE VS:GetPref
Disable RenderWorks 241 TRUE or FALSE VS:GetPref
PDF Page Object Paint Node Resolution 270 LONGINT (DPI) VS:GetPrefLongInt
Don't Cache Plug-in Scripts 407 TRUE or FALSE VS:GetPref
Auto Refresh Mode 450 TRUE or FALSE VS:GetPref
Window Zoom Factor 500 REAL VS:GetPrefReal
Layer Options 506 INTEGER VS:GetPrefInt
Class Options 507 INTEGER VS:GetPrefInt
Hide Wall Cavity Threshold 540 INTEGER VS:GetPrefInt
Save Viewport Cache 541 TRUE or FALSE VS:GetPref
Smooth Mesh 542 TRUE or FALSE VS:GetPref
Mesh Crease Angle 543 REAL VS:GetPrefReal
Use Auto Draw Coord 544 TRUE or FALSE VS:GetPref
Show Text Files in Plugin Editor 560 TRUE or FALSE VS:GetPref
Release Version Integer 570 INTEGER VS:GetPrefInt
Symbol Tool Insert Mode 580 INTEGER VS:GetPrefInt
Symbol Tool Wall Insertion 581 TRUE or FALSE VS:GetPref
Symbol Tool Alignement Mode 582 INTEGER VS:GetPrefInt
Parametric Enable State Eventing 590 INTEGER VS:GetPrefInt
Notes
Symbol Tool Insert Mode:
1 - Regular Insertion
2 - Offset Insertion
3 - Pick-up Mode
Symbol Tool Alignement Mode:
1 - Left
2 - Center
3 - Right
4 - Natural