VS:Function Reference Appendix: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:54, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Appendix D - Vectorworks Object Types and Subtypes

The numeric types in the table below are useful for identifying what type of object is referenced by a handle. The function GetTypeN(h) will return one of these numeric types. The Criteria values in the table below are used in search criteria statements. They are used along with the criteria T= to search for objects of a specific type. For example, the following statement will count the number of rectangles in the active document:

Message(Count(T=RECT));

Object Types

Object Type Criteria
Line 2 LINE
Rectangle 3 RECT
Oval 4 OVAL
Polygon 5 POLY
Arc 6 ARC
Freehand 8 FHAND
3D Locus 9 LOCUS3D
Text 10 TEXT
Group 11 GROUP
Rounded rectangle 13 RRECT
Bitmap Image 14 BITMAP
Symbol in document 15 SYMBOL
Symbol definition 16
2D Locus 17 LOCUS
Worksheet 18 SPRDSHEET
Polyline 21 POLYLINE
PICT Image 22 PICT
Extrude 24 XTRD
3D Polygon 25 POLY3D
Layer Link 29 LAYERLINK
Layer 31
Sweep 34 SWEEP
Multiple extrude 38 MXTRD
Mesh 40 MESH
Mesh vertex 41
Record Definition (Format) 47
Record 48
Document script (1) 49
Script palette (1) 51
Worksheet container 56
Dimension 63 DIMENSION
Hatch definition (1) 66
Wall 68 WALL
Column, Floor, Roof Face 71 SLAB
Light 81 LIGHT
Roof edge 82
Roof object 83 ROOF
CSG Solid (Addition, Subtraction) 84 CSGSOLID
Plug-in object 86 PLUGINOBJECT
Roof element 87 ROOFELEMENT
Round walls 89 ROUNDWALL
Symbol folder 92
Texture 93
Class definition (1) 94
Texture Definition (Material) 97
Solid (Cone, Sphere, ...) 95 SOLID
NURBS Curve 111 NURBSCURVE
NURBS Surface 113 NURBSSURFACE
Image Fill Definition (1) 119
Gradient Fill Definition (1) 120
Fill Space (1) 121
ViewPort 122
Notes
  1. These special objects are not directly displayed in the document. They may contain definition information used by other objects or features.

Object Subtypes

Object Type Criteria
Directional Light 500 DIRLIGH
Spot Light 501 SPOTLIGHT
Point Light 502 POINTLIGHT
Custom Light 503 CUSTLIGH
Area Light 504 AREALIGH
Line Light 505 LINELIGH
Sheet Layer Viewport 506 REGVIEWPOR
Section Viewport 507 SECTVIEWPOR
Floor 508 FLOO
Roof Face 509 ROOFFAC
Pillar 510 PILLA
Cone 511 CON
Sphere 512 SPHER
Hemisphere 513 HEMISPHER
Circle 514 CIRCL
Opened Arc 515 OPENEDAR
Solid Subtraction 516 CSGSUBT
Solid Addition 517 CSGAD
Solid Intersection 518 CSGINTE
Solid Section 519 CSGSEC
Solid Shell 520 CSGSHEL
Chamfer 521 CSGCHAMFE
Fillet 522 CSGFILLE
Control point based NURBS surface 523 NURBSSURFCTRL
Interpolated NURBS surface 524 NURBSSURFINTER
Notes
  1. These special objects are not directly displayed in the document. They may contain definition information used by other objects or features.

Appendix E - Miscellaneous Selectors

Attribute Criteria

Attribute Type Selector Type Exampl
All Objects ALL ALL
Attached Record R 64 character STRING R IN ['Part Data'])
Class C 64 character STRING C=DOOR
Descend into Objects INOBJECT (T=RECT) & INOBJECT
Descend into Symbols INSYMBOL (T=RECT) & INSYMBOL
Fill Background FB Color index (0 to 255) FB=34
Fill Foreground FF Color index (0 to 255) FF=56
Fill Pattern FP INTEGER FP=1
Flipped Status ISFLIPPED ((S='3680 Door') & (ISFLIPPED))
Font FOT FOT=“Arial”
Font Size FSZ FSZ=10
Gradient Fill GFI GFI=“Fall”
Hatch Fill HFI HFI=“Stipple Dark”
Image Fill IFI IFI=“Stones”
Layer L 64 character STRING L="Plan1"
Line Weight LW INTEGER W=20
Location is contained within boundary of a named object LOC (LOC='MyRoom')
Marker AR INTEGER (0 - 27) AR=3
Object Name N 64 character STRING N="Joe"
Object Type T See Object Type table T=RECT
Pen Background PB Color index (0 to 255) PB=128
Pen Foreground PF Color index (0 to 255) PF=256
Pen Pattern / Line Style PP INTEGER (patterns 0 to 71) or (dash -1 to -10) PP=-1
Selected status SEL BOOLEAN SEL=TRUE
Sketch Style SST SST=“Rough”
Symbol Name S 64 character STRING S="Window"
Texture TX TX=“Glass”
Visibility Status V BOOLEAN V=TRUE
Wall Style WST WST=“Wallstyle-1”

Fill Patterns

Fill Patterns List

Color Palette

Color Palette List

Linestyles

Style Selector
Short Dash -1
Medium Dash -2
Long Dash -3
Very Long Dash -4
Dotted -5
Dash-Dot -6
Dash-Dash-Dot -7
Dash-Dot-Dot -8
Centerline -9
Break Line -10

SetTool - CallTool Selectors

Tool Selector Tool Selector
2D Selection Cursor -240 Regular Polygon -225
3D Selection Cursor -349 Clipping -226
Pan -241 Quarter Arc -227
Zoom In -242 Center Mark -228
Zoom Out -243 Number Stamp -229
Text -200 3D View Translate -300
Line -201 3D View Rotate -301
Arc -202 Walkthrough -302
Rectangle -203 Flyover -303
Polyline -204 Translate Working Plane -304
Oval -205 Rotate Working Plane -305
Fillet -206 Set Working Plane -306
2D Polygon -207 Move Working Plane -307
Wall -208 3D Reshape -308
2D Symbol -209 3D Symbol -309
Constrained Dimension -210 Extrude -310
Unconstrained Dimension -211 Slab -311
Radial-Diam Dimension -212 Align Plane -312
Angular Dimension -213 3D Polygon -313
2D Reshape -214 3D Mirror -314
2D Rotate -215 3D Rotate -315
Double Line -216 3D Locus -316
Rounded Rectangle -217 Create Light -317
Double Line Polygon -218 Round Wall -318
Chamfer -219 Create Sphere -319
Freehand -220 Create Hemisphere -320
2D Locus -221 Create Cone -321
2D Mirror -222 Wall Join -322
Leader -223 Wall Heal -323
Fill Edit -341 Cavity Join -340
Rotated Rectangle -224 Render Bitmap -324
NURBS Curve -325 Chamfer Edge -342
NURBS Circle -328 Extract Surface -346
NURBS Arc -329 Fillet Edge -343
Curve Split -326 Loft -344
Connect/Combine -327 Project and Trim -345
Shell Solid -347 Create Contours -348
Analyze Curves and Surfaces -333 Protrusion/Cutout -332

Plug-in Object Parameter Record Field Types

Field Data Type Selector
Integer 1
Boolean 2
Real 3
Text 4
Real - Coordinate Displacement 7
Text - Popup Menu Item 8
Text - Radio Button 9
Real - Coordinate Location X 10
Real - Coordinate Location Y 11
Static Text 14

Record - Worksheet Field Types

Field Data Type Selector
Integer 1
Boolean 2
Number-general 3
Text 4
Number-decimal 5
Number-decimal w/ commas 6
Number-scientific 7
Number-fractional 8
Number-dimension 9
Number-angle 10
Number-date/time 11
Number-dimension area 14
Number-dimension volume 15

Record - Worksheet Field Display Styles

Field Data Type Display Style Selector
Boolean TRUE 1
FALSE 2
Number-decimal no. decimal places 0 to 9
Number-decimal w/ commas no. decimal places 0 to 9
Number-scientific no. decimal places 0 to 9
Number-fractional rounding value 2,4,8,16,32, etc.
Number-angle degrees 1
deg-minutes 2
deg-min-seconds 3
Number-date/time mdy 1
mdy hmm 2
dmy 3
ymd 4
ymd hmm 5
d-mmm-y 6
d-mmm 7
mmm-y 8
h mm 9
h mm s 10
h mm(AM/PM) 11
h mm s(AM/PM) 12

LinearDim

  • DimType
Description Selector
Constrained Horizontal 0
Constrained Vertical 1
Horizontal Ordinate 2
Vertical Ordinate 3
Unconstrained 4
  • arrowFlag
Description Selector
Used calculated position 1
Dim line inside-outside 2
Start witness ON-OFF 256
End witness ON-OFF 512
  • textFlag
Description Selector
Used calculated position 1
Text inside-outside 2
Text above dim line 256
Text aligned to dim line 512
Force text horizontal 1024

CircularDim

  • DimType
Description Selector
Diameter dimension 0
Other circular dimensions 1
  • arrowFlag
Description Selector
Used calculated position 1
Dim line inside-outside 2
Start witness ON-OFF 256
End witness ON-OFF 512
  • textFlag
Description Selector
Used calculated position 1
Text inside-outside 2
Text above dim line 256
Text aligned to dim line 512
Force text horizontal 1024

AngularDim

  • arrowFlag
Description Selector
Used calculated position 1
Dim line inside-outside 2
Start witness ON-OFF 256
End witness ON-OFF 512
Reference angle 1024
2 reference lines 2048
  • textFlag
Description Selector
Used calculated position 1
Text inside-outside 2
Text above dim line 256
Text aligned to dim line 512
Force text horizontal 1024

Appendix F - Preference Selectors

Application Preference Selectors

Preference Selector Preference Value Function
Click-Drag Mode 0 TRUE or FALSE VS:GetPref
Offset Duplicates 1 TRUE or FALSE VS:GetPref
Full Screen Cursor 2 TRUE or FALSE VS:GetPref
Show Screen Hints 3 TRUE or FALSE VS:GetPref
Floating Datum 4 TRUE or FALSE VS:GetPref
Snap To Loci 5 TRUE or FALSE VS:GetPref
Show Rulers 6 TRUE or FALSE VS:GetPref
Show Scroll Bars 7 TRUE or FALSE VS:GetPref
No Fill Behind Text 8 TRUE or FALSE VS:GetPref
Zoom Line Thickness 9 TRUE or FALSE VS:GetPref
Black and White Only 10 TRUE or FALSE VS:GetPref
Use Layer Colors 11 TRUE or FALSE VS:GetPref
Log Time in Program 12 TRUE or FALSE VS:GetPref
Adjust Flipped Text 13 TRUE or FALSE VS:GetPref
Show Other Objects While In Group 14 TRUE or FALSE VS:GetPref
Show 3D Axis Labels 15 TRUE or FALSE VS:GetPref
Use Black Background 16 TRUE or FALSE VS:GetPref
Use Eight Selection Handles 17 TRUE or FALSE VS:GetPref
Use Sound 18 TRUE or FALSE VS:GetPref
Issue Undo Warnings 19 TRUE or FALSE VS:GetPref
Opaque SmartCursor 20 TRUE or FALSE VS:GetPref
Stop VectorScript on Warnings 21 TRUE or FALSE VS:GetPref
Left Palette Margin 22 TRUE or FALSE VS:GetPref
Right Palette Margin 23 TRUE or FALSE VS:GetPref
Use Save Reminder 24 TRUE or FALSE VS:GetPref
Show Parametric Constraints 25 TRUE or FALSE VS:GetPref
Display Minor Alerts on Mode Bar 27 TRUE or FALSE VS:GetPref
Associate Dimensions 28 TRUE or FALSE VS:GetPref
Spell Check Capitalized Words 29 TRUE or FALSE VS:GetPref
Spell Check Words in ALL CAPS 30 TRUE or FALSE VS:GetPref
Spell Check Mixed Case Words 31 TRUE or FALSE VS:GetPref
Spell Check Words With Numbers 32 TRUE or FALSE VS:GetPref
Auto Join Walls 33 TRUE or FALSE VS:GetPref
Show Page Breaks 34 TRUE or FALSE VS:GetPref
Show Grid 35 TRUE or FALSE VS:GetPref
Print Grid 36 TRUE or FALSE VS:GetPref
Snap To Grid 37 TRUE or FALSE VS:GetPref
Snap To Object 38 TRUE or FALSE VS:GetPref
Save By Time 39 TRUE or FALSE VS:GetPref
Save Confirm 40 TRUE or FALSE VS:GetPref
Save To Backup 41 TRUE or FALSE VS:GetPref
Palette Docking 43 TRUE or FALSE VS:GetPref
Create Dimensions in Dimension Class 44 TRUE or FALSE VS:GetPref
Accelerated 2D Navigation 45 TRUE or FALSE VS:GetPref
Use Vector Caching 46 TRUE or FALSE VS:GetPref
Sketch Hidden Line 47 TRUE or FALSE VS:GetPref
Snap to Edge Points 48 TRUE or FALSE VS:GetPref
Show Page Boundary 49 TRUE or FALSE VS:GetPref
Display Default Content 130 TRUE or FALSE VS:GetPref
Dimension Slash Thickness Unit 50 3 = points, 2 = mils, 1 = mm VS:GetPrefInt
3D Rotation Responsiveness 52 1(detailed)..5(responsive) VS:GetPrefInt
Custom Constraint Angle 53 REAL (degrees) VS:GetPrefReal
Snap Radius 54 INTEGER value VS:GetPrefInt
2D Conversion Resolution 55 INTEGER value VS:GetPrefInt
3D Conversion Resolution 56 INTEGER value VS:GetPrefInt
Current Document Text Size 57 REAL VS:GetPrefReal
Current Document Text Style 58 0 (Plain) VS:GetPrefInt
1 (Bold) "
2 (Italic) "
4 (Underline) "
8 (Outline [Mac only]) "
16 (Shadow [Mac only]) "
Current Document Text Justification 82 1 (Left) VS:GetPrefInt
2 (Center) "
3 (Right) "
Current Document Text Vertical Alignment 83 1 (TopBox) VS:GetPrefInt
2 (TopBaseline) "
3 (CenterBox) "
4 (BottomBaseline) "
5 (BottomBox) "
Current Document Text Vertical Spacing 84 0 (Custom Leading) VS:GetPrefInt
2 (Single) "
3 (Three Halves) "
4 (Double) "
Current Document Text Vertical Spacing Custom Value 85 REAL VS:GetPrefReal
Maximum Number of Undos 59 INTEGER VS:GetPrefInt
Undo View Changes 26 1 (never) VS:GetPrefInt
2 (combine all) "
3 (combine similar) "
4 (combine none) "
Save Interval 60 no. of minutes VS:GetPrefInt
Display Light Objects 61 0(always) VS:GetPrefInt
1(wireframe) "
2(never) "
Display 3D Loci Objects 91 0(always) VS:GetPrefInt
1(wireframe)
2(never)
Retain QuickDraw 3D Model 62 1(never)...5(always) VS:GetPrefInt
Rotated Text Display 63 0(box) VS:GetPrefInt
1(normal) "
2(high) "
Bitmap Display 64 0(box) VS:GetPrefInt
1(low res) "
2(hi res) "
Dimension Slash Thickness 65 INTEGER value (mils) VS:GetPrefInt
Hidden Line Dash Style 66 INTEGER selector VS:GetPrefInt
Hidden Line Shading 67 1(dark)...4(light) VS:GetPrefInt
Grid X 78 REAL VS:GetPrefReal
Grid Y 79 REAL VS:GetPrefReal
Page Origin X 80 REAL (current units) VS:GetPrefReal
Page Origin Y 81 REAL (current units) VS:GetPrefReal
Page Scaling Factor 70 REAL VS:GetPrefReal
Dimension Standard 71 1 (Arch) VS:GetPrefInt
2 (ASME) "
3 (BSI) "
4 (DIN) "
5 (ISO) "
6 (JIS) "
7 (SIA) "
8 (ASME Dual Side-by-Side) "
9 (ASME Dual Stacked) "
Defacet Angle 72 REAL (0-90) VS:GetPrefReal
Grid Angle 73 REAL VS:GetPrefReal
Move Objects on Grid Keys 74 1 (arrow) VS:GetPrefInt
2 (cmd+arrow) "
3 (shift+arrow) "
4 (shift+cmd+arrow) "
Nudge Objects Keys 75 1-4 (see above) VS:GetPrefInt
Pan Drawing Keys 76 1-4 (see above) VS:GetPrefInt
Switch Active Layer/Class Keys 77 1-4 (see above) VS:GetPrefInt
Default Compression 86 1 = JPEG, 2 = PNG VS:GetPrefInt
Line Weight Array Count 87 INTEGER VS:GetPrefInt
Sound Volume 88 INTEGER VS:GetPrefInt
Custom Move Distance 89 REAL VS:GetPrefReal
Plan Rotation 92 TRUE or FALSE VS:GetPref
Plan Rotation Angle 93 REAL (read-only) VS:GetPrefReal
Stack Layers 94 TRUE or FALSE VS:GetPref
Stack Layers Create 2D Objects 95 TRUE or FALSE VS:GetPref
Stack Layers Ignore Other Scales 96 TRUE or FALSE VS:GetPref
Stack Layers Restore Views 97 TRUE or FALSE VS:GetPref
Use Open MP Multithreading 98 0 (no) VS:GetPrefInt
1 (yes) "
2 (partial) "
Stack Layers Center View 99 TRUE or FALSE VS:GetPref
Text Font Name 100 STRING VS:GetPrefString
Stack Layers Show Page Boundary 101 TRUE or FALSE VS:GetPref
Stack Layers Only Active Layer 2D Objects 102 TRUE or FALSE VS:GetPref
Angular Precision 120 INTEGER VS:GetPrefInt
Angular Unit 121 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Resetting Plugin-ins During File Read 129 TRUE or FALSE VS:GetPref
Display Default Content 130 TRUE or FALSE VS:GetPref
Auto File Extensions On Mac 131 TRUE or FALSE VS:GetPref
Use Advanced Imaging 132 TRUE or FALSE VS:GetPref
Use Anti Aliasing 133 TRUE or FALSE VS:GetPref
Auto Associate Dims 134 TRUE or FALSE VS:GetPref
Mouse Wheel Zoom 135 TRUE or FALSE VS:GetPref
Use Custom Move Distance 136 TRUE or FALSE VS:GetPref
Print Switch Binary 137 TRUE or FALSE VS:GetPref
Unit1 Dim Fraction Display Style 190 0 (regular style) VS:GetPrefInt
1 (diagonal style)
2 (horizontal style)
DXF Add Prefix To DXF Layers 328 TRUE or FALSE VS:GetPref
DXF Prefix To DXF Edit 329 STRING value VS:GetPrefString
DXF External Refs Handling 330 0 (Bind External Refs) VS:GetPrefInt
1 (Ignore External Refs)
2 (Create VW Refs)
3 (Use Layer Import)
DXF ADT Objects 2D View 331 TRUE or FALSE VS:GetPref
Use Framed Highlighting 410 TRUE or FALSE VS:GetPref
Smart Cursor Show Interactive Segment 411 TRUE or FALSE VS:GetPref
Snap To Tool Snap Geometry Only 460 TRUE or FALSE VS:GetPref
whether to coordinate sheet and drawing numbers for various items 544 TRUE or FALSE VS:GetPref
Auto Save To Custom Location 552 TRUE or FALSE VS:GetPref
Autosave Custom Location 554 STRING value VS:GetPrefString
Keep Backups By Number Value 555 TRUE or FALSE VS:GetPref
Center View 558 TRUE or FALSE VS:GetPref
Release Version Integer 570 SHORT - The release version integer defaults to 0 VS:GetPrefInt
get/set the insertion mode of the symbol tool 580 SHORT VS:GetPrefInt
get/set the wall insertion mode of the symbol tool 581 SHORT VS:GetPrefInt
get/set the alignment mode of the symbol tool 582 SHORT VS:GetPrefInt
Parametric Enable State Eventing 590 0 (NoStateEvents) VS:GetPrefInt
1 (ResetStatesEvent)
2 (InternalStatesEvent)

Primary Units Selectors

Preference Selector Preference Data Type Function
Unit Fraction 150 REAL value VS:GetPrefReal
Units Per Inch 152 REAL value VS:GetPrefReal
Unit Style Name 153 STRING value VS:GetPrefString
Unit Mark 154 STRING value VS:GetPrefString
Sunit Mark 155 STRING value VS:GetPrefString
Sunit Divider 156 STRING value VS:GetPrefString
Smultiplier 157 INTEGER value VS:GetPrefInt
Square Unit Mark 158 STRING value VS:GetPrefString
Square Unit Divisor 159 LONGINT VS:GetPrefLongInt
Cube Unit Mark 160 STRING value VS:GetPrefString
Cube Unit Divisor 161 LONGINT VS:GetPrefLongInt
Display Fraction 162 LONGINT value VS:GetPrefLongInt
Show Unit Mark 163 TRUE or FALSE VS:GetPref
Display Leading Zero 164 TRUE or FALSE VS:GetPref
Display Trailing Zeroes 165 TRUE or FALSE VS:GetPref
Use Minimum Units 166 TRUE or FALSE VS:GetPref
Use Custom Units 167 TRUE or FALSE VS:GetPref
Show Decimals as Fractions 168 TRUE or FALSE VS:GetPref
Dimension Precision 169 LONGINT value VS:GetPrefLongInt
Predefined Units Style 170 1 (Feet & Inches) VS:GetPrefInt
2 (Inches)
3 (Feet)
4 (Yards)
5 (Miles)
6 (Microns)
7 (Millimeters)
8 (Centimeters)
9 (Meters)
10 (Kilometers)
11 (Degrees – Landmark & Azimuth only)
Fractional Display Precision 171 LONGINT value VS:GetPrefLongInt
Fractional Dimension Precision 172 LONGINT value VS:GetPrefLongInt
Metric Unit Flag 173 TRUE or FALSE VS:GetPref
Angular Unit 174 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Round Fraction to Decimal 175 TRUE or FALSE VS:GetPref
Area Units Per Square Inch 176 REAL value VS:GetPrefReal
Area Unit Name 177 STRING value VS:GetPrefString
Area Unit Mark 178 STRING value VS:GetPrefString
Area Precision 179 LONGINT value VS:GetPrefLongInt
Volume Units Per Cubic Inch 180 REAL value VS:GetPrefReal
Volume Unit Name 181 STRING value VS:GetPrefString
Volume Unit Mark 182 STRING value VS:GetPrefString
Volume Precision 183 LONGINT value VS:GetPrefLongInt
Use Custom Area Units 184 TRUE or FALSE VS:GetPref
Use Custom Volume Units 185 TRUE or FALSE VS:GetPref
Area Unit Fraction 186 REAL value VS:GetPrefReal
Volume Unit Fraction 187 REAL value VS:GetPrefReal
Display Rounding Base 188 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)
Dimension Rounding Base 189 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)
Dimension Rounding Base 190 0 (regular style) VS:GetPrefInt
1 (diagonal style)
2 (horizontal style)

Secondary Units Selectors

Preference Selector Preference Data Type Function
Unit Fraction 200 REAL value VS:GetPrefReal
Units Per Inch 202 REAL value VS:GetPrefReal
Unit Style Name 203 64 character STRING VS:GetPrefString
Unit Mark 204 STRING value VS:GetPrefString
Sunit Mark 205 STRING value VS:GetPrefString
Sunit Divider 206 STRING value VS:GetPrefString
Smultiplier 207 INTEGER value VS:GetPrefInt
Square Unit Mark 208 STRING value VS:GetPrefString
Square Unit Divisor 209 LONGINT VS:GetPrefLongInt
Cube Unit Mark 210 STRING value VS:GetPrefString
Cube Unit Divisor 211 LONGINT value VS:GetPrefLongInt
Display Fraction 212 LONGINT value VS:GetPrefLongInt
Show Unit Mark 213 TRUE or FALSE VS:GetPref
Display Leading Zero 214 TRUE or FALSE VS:GetPref
Display Trailing Zeroes 215 TRUE or FALSE VS:GetPref
Use Minimum Units 216 TRUE or FALSE VS:GetPref
Use Custom Units 217 TRUE or FALSE VS:GetPref
Show Decimals as Fractions 218 TRUE or FALSE VS:GetPref
Dimension Precision 219 LONGINT value VS:GetPrefLongInt
Predefined Units Style 220 1 (Feet & Inches) VS:GetPrefInt
2 (Inches)
3 (Feet)
4 (Yards)
5 (Miles)
6 (Microns)
7 (Millimeters)
8 (Centimeters)
9 (Meters)
10 (Kilometers)
11 (Degrees – Landmark & Azimuth only)
Fractional Display Precision 221 LONGINT value VS:GetPrefLongInt
Fractional Dimension Precision 222 LONGINT value VS:GetPrefLongInt
Metric Unit Flag 223 TRUE or FALSE VS:GetPref
Angular Unit 224 0 (degrees) VS:GetPrefInt
1 (radians)
2 (gradians)
Round Fraction to Decimal 225 TRUE or FALSE VS:GetPref
Dimension Rounding Base 226 0 (1) VS:GetPrefInt
1 (2.5)
2 (5)

DXF Preference Selectors

Preference Selector Preference Data Type Function
Auto Units 300 TRUE or FALSE VS:GetPref
Units 301 INTEGER VS:GetPrefInt
DXF Units Per Inch 302 REAL VS:GetPrefReal
Auto Model Space Scale 303 TRUE or FALSE VS:GetPref
Model Space Scale 304 REAL VS:GetPrefReal
2D 3D Import Handling 305 INTEGER VS:GetPrefInt
Map Layers to Classes 306 TRUE or FALSE VS:GetPref
Convert Mlines to Walls 307 TRUE or FALSE VS:GetPref
Convert Rays and Xlines 308 TRUE or FALSE VS:GetPref
Scale Dash Lengths 309 TRUE or FALSE VS:GetPref
Dash Length Scale 310 REAL VS:GetPrefReal
Auto Block Attribute Handling 311 TRUE or FALSE VS:GetPref
Block Attribute Handling 312 INTEGER VS:GetPrefInt
Auto Point Handling 313 TRUE or FALSE VS:GetPref
Convert Points to Loci 314 TRUE or FALSE VS:GetPref
Point Symbols are Guides 315 TRUE or FALSE VS:GetPref
Map Colors to Line Weights 316 TRUE or FALSE VS:GetPref
Set Line Colors Black 317 TRUE or FALSE VS:GetPref
Paper Space Units 318 INTEGER VS:GetPrefInt
Auto Scale Dash Lengths 319 TRUE or FALSE VS:GetPref
Group Record Fields 320 TRUE or FALSE VS:GetPref
Auto Line Weight Handling 321 TRUE or FALSE VS:GetPref
Convert Dimensions To Groups 322 TRUE or FALSE VS:GetPref
Rays and Lines To Guides 323 TRUE or FALSE VS:GetPref
Auto Center After Import 324 TRUE or FALSE VS:GetPref
Center After Import 325 TRUE or FALSE VS:GetPref
Use World Origin 326 TRUE or FALSE VS:GetPref
Set Vectorworks Units To Match 327 TRUE or FALSE VS:GetPref
Add Prefix To DXF Layers 328 TRUE or FALSE VS:GetPref
Prefix To DXF Edit 329 STRING value VS:GetPrefString
External Refs Handling 330 0 (bind external refs) VS:GetPrefInt
1 (ignore external refs) "
2 (create VW refs) "
3 (use layer import) "
ADT Objects 2D View 331 TRUE or FALSE VS:GetPref

Gradient and Image Fill Preference Selectors

Preference Selector Preference Data Type Function
Default Gradient Fill 508 LONGINT VS:GetPrefLongInt
Default Gradient Fill Angle 512 REAL VS:GetPrefReal
Default Gradient Fill Repeat 513 TRUE or FALSE VS:GetPref
Default Gradient Fill Geometric Type 515 INTEGER VS:GetPrefInt
Default Gradient Fill Mirror 516 TRUE or FALSE VS:GetPref
Default Image Fill Maintain Aspect Ratio 517 TRUE or FALSE VS:GetPref
Default Image Fill 518 LONGINT VS:GetPrefLongInt
Default Image Fill Angle 523 REAL VS:GetPrefReal
Default Image Fill Repeat 524 TRUE or FALSE VS:GetPref
Default Image Fill Mirror 526 TRUE or FALSE VS:GetPref
Default Image Fill Flip 527 TRUE or FALSE VS:GetPref
Default Image Fill I-Length 532 REAL (current units) VS:GetPrefReal
Default Image Fill J-Length 533 REAL (current units) VS:GetPrefReal
Default Fill Style 528 LONGINT VS:GetPrefLongInt
Default Fill Type 529 INTEGER VS:GetPrefInt
Default Hatch Fill 530 LONGINT VS:GetPrefLongInt

Misc. Preference Selectors

Preference Selector Preference Data Type Function
RenderWorks Enabled 240 TRUE or FALSE VS:GetPref
Disable RenderWorks 241 TRUE or FALSE VS:GetPref
PDF Page Object Paint Node Resolution 270 LONGINT (DPI) VS:GetPrefLongInt
Don't Cache Plug-in Scripts 407 TRUE or FALSE VS:GetPref
Auto Refresh Mode 450 TRUE or FALSE VS:GetPref
Window Zoom Factor 500 REAL VS:GetPrefReal
Layer Options 506 INTEGER VS:GetPrefInt
Class Options 507 INTEGER VS:GetPrefInt
Hide Wall Cavity Threshold 540 INTEGER VS:GetPrefInt
Save Viewport Cache 541 TRUE or FALSE VS:GetPref
Smooth Mesh 542 TRUE or FALSE VS:GetPref
Mesh Crease Angle 543 REAL VS:GetPrefReal
Use Auto Draw Coord 544 TRUE or FALSE VS:GetPref
Show Text Files in Plugin Editor 560 TRUE or FALSE VS:GetPref
Release Version Integer 570 INTEGER VS:GetPrefInt
Symbol Tool Insert Mode 580 INTEGER VS:GetPrefInt
Symbol Tool Wall Insertion 581 TRUE or FALSE VS:GetPref
Symbol Tool Alignement Mode 582 INTEGER VS:GetPrefInt
Parametric Enable State Eventing 590 INTEGER VS:GetPrefInt
Notes
Symbol Tool Insert Mode:
1 - Regular Insertion
2 - Offset Insertion
3 - Pick-up Mode
Symbol Tool Alignement Mode:
1 - Left
2 - Center
3 - Right
4 - Natural

Appendix G - Object Selectors

Dimensions

Object Setting Selector Setting Value Function Type
Dimension Standard 0 1 (Arch) VS:GetObjectVariableInt
2 (ASME) "
3 (BSI) "
4 (DIN) "
5 (ISO) "
6 (JIS) "
7 (SIA) "
8 (ASME Dual Side-by-Side) "
9 (ASME Dual Stacked) "
Arrows Inside 3 TRUE or FALSE VS:GetObjectVariableBoolean
Use Text Box (Primary Value) 5 TRUE or FALSE VS:GetObjectVariableBoolean
Show Primary Dimension Text 6 TRUE or FALSE VS:GetObjectVariableBoolean
Display Starting Witness Line 7 TRUE or FALSE VS:GetObjectVariableBoolean
Display Ending Witness Line 8 TRUE or FALSE VS:GetObjectVariableBoolean
Leader Text (Primary) 9 31 character STRING value VS:GetObjectVariableString
Trailer Text (Primary) 10 31 character STRING value VS:GetObjectVariableString
Dimension Tolerancing 11 0 (no tolerance) VS:GetObjectVariableInt
1 (single tolerance) "
2 (double tolerance) "
3 (limit tolerance) "
Dimension Text Offset 15 REAL VS:GetObjectVariableReal
Dimension Text Font Size 17 REAL VS:GetObjectVariableReal
Dimension Text Font Style 19 0 (Plain) VS:GetObjectVariableInt
1 (Bold) "
2 (Italic) "
4 (Underline) "
8 (Outline [Mac only]) "
16 (Shadow [Mac only]) "
Dimension Precision (Primary) 20 For decimal precision: value is digits after decimal point. VS:GetObjectVariableLongInt
For fractional precision: value is power of 2 for fractional denominator (1 for 1/2, 2 for 1/4, 3 for 1/8, 4 for 1/16, etc). "
For angular precision: 1 for whole number, 2 (degrees min), 3 (degrees min sec), 5 (x.x angular units), 6 (x.xx), 7 (x.xxx), 8 (x.xxxx), 9 (x.xxxxx), 10 (x.xxxxxx), 11 (x.xxxxxxx), 12 (x.xxxxxxxx) "
Dimension Precision (Secondary) 21 For decimal precision: value is digits after decimal point. VS:GetObjectVariableLongInt
For fractional precision: value is power of 2 for fractional denominator (1 for 1/2, 2 for 1/4, 3 for 1/8, 4 for 1/16, etc). "
For angular precision: value is not used. "
Use Text Box (Secondary) 22 TRUE or FALSE VS:GetObjectVariableBoolean
Show Secondary Dimension Text 23 TRUE or FALSE VS:GetObjectVariableBoolean
Leader Text (Secondary) 24 31 character STRING value VS:GetObjectVariableString
Trailer Text (Secondary) 25 31 character STRING value VS:GetObjectVariableString
Dimension Type 26 0 (Constrained) VS:GetObjectVariableInt
1 (Unconstrained) "
2 (Ordinate) "
3 (Radial) "
4 (Diameter) "
5 (Angular) "
Dimension Standard Name 27 STRING value VS:GetObjectVariableString
Dimension Font ID 28 Font ID VS:GetObjectVariableInt
Calculate Dim Text Position 29 TRUE or FALSE VS:GetObjectVariableBoolean
Force Dim Text Inside 30 TRUE or FALSE VS:GetObjectVariableBoolean
Angle is Reference 31 TRUE or FALSE VS:GetObjectVariableBoolean
Show Only Primary 32 TRUE or FALSE VS:GetObjectVariableBoolean
Show Only Secondary 33 TRUE or FALSE VS:GetObjectVariableBoolean
Top Tolerance Value 34 REAL value VS:GetObjectVariableReal
Bottom Tolerance Value 35 REAL value VS:GetObjectVariableReal
Top Tolerance String 36 STRING VS:GetObjectVariableString
Bottom Tolerance String 37 STRING VS:GetObjectVariableString
Use Tolerance Strings 38 TRUE or FALSE VS:GetObjectVariableBoolean
Flip Text 39 TRUE or FALSE VS:GetObjectVariableBoolean
Dimension Text Font Size 40 in points VS:GetObjectVariableReal
Dimension Text Rotation 41 0 = Aligned, 1 = Horizontal, 2 = Horiz/Vertical VS:GetObjectVariableInt
Dim Text Offset Above Line 43 REAL (current units) VS:GetObjectVariableReal
Dim Text Offset 44 REAL value VS:GetObjectVariableReal
Dimension Offset 45 REAL (current units) VS:GetObjectVariableReal
Show Elevation Dimension (SIA Only) 46 TRUE or FALSE VS:GetObjectVariableBoolean
Elevation Dimension Value (SIA Only) 47 REAL value VS:GetObjectVariableReal
Leader Text for Elevation Dimension (SIA Only) 48 31 character STRING value VS:GetObjectVariableString
Trailer Text for Elevation Dimension (SIA Only) 49 31 character STRING value VS:GetObjectVariableString

Lights

Object Setting Selector Setting Value Function
Light On 50 TRUE or FALSE VS:GetObjectVariableBoolean
Brightness 51 REAL (percentage) VS:GetObjectVariableReal
Shadow Casting On 53 TRUE or FALSE VS:GetObjectVariableBoolean
Light Type 55 1 (Directional) VS:GetObjectVariableInt
2 (Point) "
3 (Spotlight) "
Light Pan Angle 57 REAL value VS:GetObjectVariableReal
Light Tilt Angle 58 REAL value VS:GetObjectVariableReal
Distance Falloff Type 59 0 (None) VS:GetObjectVariableInt
1 (Smooth) "
2 (Sharp) "
Angular Falloff Type 60 0 (none) VS:GetObjectVariableInt
1 (Normal) "
2 (Smooth) "
3 (Sharp) "
Light Spread Angle 61 REAL value VS:GetObjectVariableReal
Beam Angle 62 REAL value VS:GetObjectVariableReal
Light Lit Fog 63 TRUE or FALSE VS:GetObjectVariableBoolean

Symbols

Object Setting Selector Setting Value Function
Symbol Light Multiplier 100 REAL value VS:GetObjectVariableReal
Symbol Insert Mode 125 0 (On center of wall) VS:GetObjectVariableInt
1 (On edge of wall) "
Symbol Break Mode 126 1 (Full break) VS:GetObjectVariableInt
2 (Full break no caps) "
3 (Half break) "
4 (no break) "
Insert As Group 127 TRUE or FALSE VS:GetObjectVariableBoolean
Use Class of Symbol Definition 128 TRUE or FALSE VS:GetObjectVariableBoolean
Symbol Definition Insert Into Walls 129 TRUE or FALSE VS:GetObjectVariableBoolean

Roofs,Floors,Columns

Object Setting Selector Setting Value Function
Slab Type 172 1 (Roof) VS:GetObjectVariableInt
2 (Floor) "
3 (Column) "
Slab Thickness 173 REAL (current units) VS:GetObjectVariableReal
Slab Height 174 REAL (current units) (1) VS:GetObjectVariableReal
Roof Edge Miter Type 180 1 (Vertical) VS:GetObjectVariableInt
2 (Horizontal) "
3 (Compound) "
Double Miter Ratio Value 181 REAL value (3 ) VS:GetObjectVariableReal
Roof Rise 182 REAL (current units) (2) VS:GetObjectVariableReal
Roof Run 183 REAL (current units) (2) VS:GetObjectVariableReal
Notes
  1. Height is the bottom of the slab for floors and columns, elevation of the roof axis for roofs.
  2. Roof only.
  3. A value between 0 and 1 indicating the percentage of the miter which is vertical.

Layer

Object Setting Selector Setting Value Function
Layer Ambient Status 150 TRUE or FALSE VS:GetObjectVariableBoolean
Layer Ambient Brightness 151 REAL value VS:GetObjectVariableReal
Layer Visibility 153 -1 (Invisible) VS:GetObjectVariableInt
0 (Normal) "
2 (Grayed) "
Layer Type 154 INTEGER VS:GetObjectVariableInt
Layer Printing DPI 155 INTEGER VS:GetObjectVariableInt
Layer Renderworks Background 591 LONGINT VS:GetObjectVariableLongInt
Layer Repaginate 156 TRUE or FALSE VS:GetObjectVariableBoolean
Layer Height 157 REAL (current units) VS:GetObjectVariableReal
Layer Thickness 158 REAL (current units) VS:GetObjectVariableReal
Layer Description 159 STRING value VS:GetObjectVariableString
HDRI Layer 592 LONGINT VS:GetObjectVariableLongInt

Layer Link

Object Setting Selector Setting Value Function
Source Layer Name 160 STRING value VS:GetObjectVariableString
Project 2D Objects 161 TRUE or FALSE VS:GetObjectVariableBoolean
Layer Expanded Sheet Name 162 STRING value VS:GetObjectVariableString

Viewports

Object Setting Selector Setting Value Function
Projection Type 1000 INTEGER VS:GetObjectVariableInt
Render Type 1001 INTEGER VS:GetObjectVariableInt
Perspective Distance 1002 REAL VS:GetObjectVariableReal
Scale 1003 REAL VS:GetObjectVariableReal
Needs Update 1004 TRUE of FALSE VS:GetObjectVariableBoolean
Project 2D 1005 TRUE of FALSE VS:GetObjectVariableBoolean
Render Background 1006 LONGINT VS:GetObjectVariableLongInt
View Type 1007 INTEGER VS:GetObjectVariableInt
Line Weight Scale 1008 REAL VS:GetObjectVariableReal
Arrowhead Scale 1009 REAL VS:GetObjectVariableReal
Dashed Line Scale 1010 REAL VS:GetObjectVariableReal
Hatch Line Scale 1011 REAL VS:GetObjectVariableReal
Design Text Scale 1012 REAL VS:GetObjectVariableReal
Slash Thickness Scale 1013 REAL VS:GetObjectVariableReal
Ambient light is ON 1014 TRUE or FALSE VS:GetObjectVariableBoolean
Ambient Light Brightness 1015 REAL VS:GetObjectVariableReal
Design Layer Visibility In All Viewports 1017 INTEGER VS:GetObjectVariableInt
Class Visibility In All Viewports 1018 INTEGER VS:GetObjectVariableInt
HDRI Viewport 1019 LONGINT VS:GetObjectVariableLongInt
2D Class Attributes 1020 LONGINT VS:GetObjectVariableLongInt
2D Other Attributes 1021 LONGINT VS:GetObjectVariableLongInt
3D Class Fill Style 1022 LONGINT VS:GetObjectVariableLongInt
3D Class Line Style 1023 LONGINT VS:GetObjectVariableLongInt
Viewport x Position 1024 REAL VS:GetObjectVariableReal
Viewport y Position 1025 REAL VS:GetObjectVariableReal
Angle With Axis 1026 REAL VS:GetObjectVariableReal
Shadow Wall Components 1027 TRUE or FALSE VS:GetObjectVariableBoolean
Gray Transparent 1028 TRUE or FALSE VS:GetObjectVariableBoolean
Flip Text 1029 TRUE or FALSE VS:GetObjectVariableBoolean
Black and White 1030 TRUE or FALSE VS:GetObjectVariableBoolean
Viewport Use Document Class Visibility 1031 TRUE or FALSE VS:GetObjectVariableBoolean
Viewport Description 1032 STRING value VS:GetObjectVariableString
Viewport Locator 1033 STRING value VS:GetObjectVariableString
Viewport Is Linked 1032 TRUE or FALSE VS:GetObjectVariableBoolean
Viewport Display Planar 1035 TRUE or FALSE VS:GetObjectVariableBoolean
Viewport Foreground Render Type 1036 INTEGER VS:GetObjectVariableInt
Notes
  1. View Type values are different then SetView
viewUserDefined 0
viewFront 3
viewBack 4
viewLeft 5
viewRight 6
viewTop 7
viewBottom 8
viewRightIso 9
viewLeftIso 10
viewRightRearIso= 11;
viewLeftRearIso 12
viewBottomRightIso= 13;
viewBottomLeftIso= 14;
viewBottomRightRearIso 15
viewBottomLeftRearIso 16

Walls

Object Setting Selector Setting Value Function
Number of Cavities 199 INTEGER value (1) VS:GetObjectVariableInt
Cavity is Pair 240 TRUE or FALSE VS:GetObjectVariableBoolean
Cavity Fill Pattern 260 LONGINT index (0-71) (2) VS:GetObjectVariableLongInt
Cavity Pen Weight 280 INTEGER value (mils) (2) VS:GetObjectVariableInt
Cavity Pen Style 300 INTEGER index (2) VS:GetObjectVariableInt
Cavity Left Offset 320 REAL (2) VS:GetObjectVariableReal
Cavity Right Offset 340 REAL (2) VS:GetObjectVariableReal
Hide Cavity Detail 701 TRUE or FALSE VS:GetObjectVariableBoolean
Counterclockwise Round Wall 570 TRUE or FALSE VS:GetObjectVariableBoolean
Round Wall Radius 571 REAL VS:GetObjectVariableReal
Wall Left Gross Area 608 REAL VS:GetObjectVariableReal
Wall Right Gross Area 609 REAL VS:GetObjectVariableReal
Wall Gross Area 610 REAL VS:GetObjectVariableReal
Wall Left Net Area 611 REAL VS:GetObjectVariableReal
Wall Right Net Area 612 REAL VS:GetObjectVariableReal
Wall Net Area 613 REAL VS:GetObjectVariableReal
Wall Left Average Height 614 REAL VS:GetObjectVariableReal
Wall Right Average Height 615 REAL VS:GetObjectVariableReal
Wall Average Height 616 REAL VS:GetObjectVariableReal
Notes
  1. Pass NIL to access default cavity values.
  2. To access different cavities within a wall, add the zero-based cavity index to the selector value. For example, to access the right offset of cavity 6, specify 346 (340 + 6).

Wall and Slab Styles

Object Setting Selector Setting Value Function
Thickness 1177 REAL (1) VS:GetObjectVariableReal
Fill 1178 LONGINT Pattern (0 to 71) or negative resource fill ref number VS:GetObjectVariableLongInt
Pen Style 1179 INTEGER Pattern (0 to 71) or dash (-1 to -10) VS:GetObjectVariableInt
Pen Weight 1180 INTEGER VS:GetObjectVariableInt
Fill Foreground Color 1181 INTEGER Color index (0 to 255) VS:GetObjectVariableInt
Fill Background Color 1182 INTEGER Color index (0 to 255) VS:GetObjectVariableInt
Pen Foreground Color 1183 INTEGER Color index (0 to 255) VS:GetObjectVariableInt
Pen Background Color 1184 INTEGER Color index (0 to 255) VS:GetObjectVariableInt
Opacity 1185 INTEGER Percent (0 to 100) VS:GetObjectVariableInt
Use Fill Class Attributes 1186 TRUE or FALSE VS:GetObjectVariableBoolean
Use Pen Class Attributes 1187 TRUE or FALSE VS:GetObjectVariableBoolean
Use Class Opacity 1188 TRUE or FALSE VS:GetObjectVariableBoolean
Cap Attributes Type 1189 INTEGER (0 = Wall line, 1 = Component lines) (2) VS:GetObjectVariableInt
Caps 1194 INTEGER (0 = None, 1 = Start, 2 = End, 3 = Both) (2) VS:GetObjectVariableInt
Class 1195 LONGINT Ref number VS:GetObjectVariableLongInt
Control Offset 1196 REAL (2) VS:GetObjectVariableReal
Texture Set 1197 INTEGER (0 = Object textures, 1 = Component textures) VS:GetObjectVariableInt
Overall Texture 1198 LONGINT Ref number VS:GetObjectVariableLongInt
Left Texture 1199 LONGINT Ref number (2) VS:GetObjectVariableLongInt
Right Texture 1200 LONGINT Ref number (2) VS:GetObjectVariableLongInt
Start Cap Texture 1201 LONGINT Ref number (2) VS:GetObjectVariableLongInt
End Cap Texture 1202 LONGINT Ref number (2) VS:GetObjectVariableLongInt
Top Texture 1203 LONGINT Ref number VS:GetObjectVariableLongInt
Bottom Texture 1204 LONGINT Ref number VS:GetObjectVariableLongInt
Holes Texture 1205 LONGINT Ref number (2) VS:GetObjectVariableLongInt
Sides Texture 1206 LONGINT Ref number (3) VS:GetObjectVariableLongInt
Mark 1207 STRING VS:GetObjectVariableString
Description 1208 STRING VS:GetObjectVariableString
Function 1209 STRING VS:GetObjectVariableString
Exterior 1210 TRUE or FALSE VS:GetObjectVariableBoolean
Load Bearing 1211 TRUE or FALSE VS:GetObjectVariableBoolean
Fire Rating 1212 STRING VS:GetObjectVariableString
Combustible Construction 1213 TRUE or FALSE VS:GetObjectVariableBoolean
Compartmentation 1214 TRUE or FALSE VS:GetObjectVariableBoolean
U-Value 1215 REAL VS:GetObjectVariableReal
R-Value 1216 REAL VS:GetObjectVariableReal
Acoustic Rating 1217 STRING VS:GetObjectVariableString
Cost Index System 1218 STRING VS:GetObjectVariableString
Cost Index Code 1219 STRING VS:GetObjectVariableString
Model 1220 STRING VS:GetObjectVariableString
Manufacturer 1221 STRING VS:GetObjectVariableString
URL 1222 STRING VS:GetObjectVariableString
Notes
  1. Wall Styles and read-only for Slab Styles
  2. Wall Styles only
  3. Slab Styles only

Plug-in Objects

Object Setting Selector Setting Value Function
Insertion Mode 123 0 (On center of wall) VS:GetObjectVariableInt
1 (On edge of wall) "
Break Mode 124 1 (Full break) VS:GetObjectVariableInt
2 (Full break no caps) "
3 (Half break) "
4 (no break) "
Font Style Enabled 800 TRUE or FALSE VS:GetObjectVariableBoolean

2D - 3D Status

Object Setting Selector Setting Value Function
Object Is 3D 650 TRUE or FALSE (read-only) VS:GetObjectVariableBoolean
Object Is 2D 651 TRUE or FALSE (read-only) VS:GetObjectVariableBoolean

Worksheets

Object Setting Selector Setting Value Function
Worksheet Header 80 STRING value VS:GetObjectVariableString
Worksheet Footer 81 STRING value VS:GetObjectVariableString
Show Database Headers 82 TRUE or FALSE VS:GetObjectVariableBoolean
Show Gridlines 83 TRUE or FALSE VS:GetObjectVariableBoolean
Show Tabs 84 TRUE or FALSE VS:GetObjectVariableBoolean
Auto-Recalculate 85 TRUE or FALSE VS:GetObjectVariableBoolean
Default Font Index 86 INTEGER value VS:GetObjectVariableInt
Default Font Size 87 INTEGER value VS:GetObjectVariableInt
Top Print Margin 88 REAL value VS:GetObjectVariableReal
Left Print Margin 89 REAL value VS:GetObjectVariableReal
Bottom Print Margin 90 REAL value VS:GetObjectVariableReal
Right Print Margin 91 REAL value VS:GetObjectVariableReal

Textures

Object Setting Selector Data Type Function
Texturable Object 500 TRUE or FALSE (read-only) VS:GetObjectVariableBoolean
Expanded Material Set 501 TRUE or FALSE (1) VS:GetObjectVariableBoolean
Material Size 511 REAL (current units) VS:GetObjectVariableReal
Texture Bitmap Horiz Repeat 524 TRUE or FALSE VS:GetObjectVariableBoolean
Texture Bitmap Vertical Repeat 525 TRUE or FALSE VS:GetObjectVariableBoolean
Texture Bitmap Feature Size 527 REAL (current units) VS:GetObjectVariableReal
Paint Width 530 LONGINT (pixels) VS:GetObjectVariableInt
Paint Height 531 LONGINT (pixels) VS:GetObjectVariableInt
Texture Space Type 540 0 (Plane) VS:GetObjectVariableInt
1 (Sphere) "
2 (Cylinder) "
3 (Algorithmic/Perimeter) "
4 (Shader) "
Texture Space Scale 543 REAL VS:GetObjectVariableReal
Texture Space Rotation 544 REAL value (in radians) VS:GetObjectVariableReal
Texture Space Use Start Cap 546 TRUE or FALSE (3) VS:GetObjectVariableBoolean
Texture Space Use End Cap 547 TRUE or FALSE (3) VS:GetObjectVariableBoolean
Texture Space Part ID 548 INTEGER index (4) VS:GetObjectVariableInt
Texture Space Radius 549 REAL (current units) (2) VS:GetObjectVariableReal
Same Texture as Parent Wall 704 TRUE or FALSE VS:GetObjectVariableBoolean
Notes
  1. Sets whether multiple textures can be applied to object (two for roof, three for walls).
  2. Valid for sphere texture space only.
  3. Valid for extrudes and sweeps only.
  4. Index of multi-texturable object component.

Gradient, Image, Tile and Hatch Fills

Object Setting Selector Data Type Function
Fill X Offset 70 REAL VS:GetObjectVariableReal
Fill Y Offset 71 REAL VS:GetObjectVariableReal
Fill I-Axis Length 72 REAL VS:GetObjectVariableReal
Fill J-Axis Length 73 REAL VS:GetObjectVariableReal
Fill Angle 74 REAL (radians) VS:GetObjectVariableReal
Fill Repeat 75 TRUE or FALSE VS:GetObjectVariableBoolean
Fill Mirror 76 TRUE or FALSE VS:GetObjectVariableBoolean
Image Flip 77 TRUE or FALSE VS:GetObjectVariableBoolean
Gradient Geometry Type 78 LONGINT VS:GetObjectVariableLongInt
Image Aspect Ratio 79 TRUE or FALSE VS:GetObjectVariableBoolean
Fill X Offset 110 REAL (current units) VS:GetObjectVariableReal
Fill Y Offset 111 REAL (current units) VS:GetObjectVariableReal
Fill I-Axis Length 112 REAL (current units) VS:GetObjectVariableReal
Fill J-Axis Length 113 REAL (current units) VS:GetObjectVariableReal
Image Width in Pixels 534 LONGINT VS:GetObjectVariableLongInt
Image Width in Pixels 535 LONGINT VS:GetObjectVariableLongInt

Hatches

Object Setting Selector Data Type Function
Number of Levels 660 INTEGER VS:GetObjectVariableInt
Is Transparent 661 TRUE or FALSE VS:GetObjectVariableBoolean
Has Page Units 662 TRUE or FALSE VS:GetObjectVariableBoolean
Rotate In Wall 663 TRUE or FALSE VS:GetObjectVariableBoolean
Rotate In Symbol 664 TRUE or FALSE VS:GetObjectVariableBoolean

Misc.

Object Setting Selector Data Type Function
Is 2D Poly Clockwise 652 TRUE or FALSE VS:GetObjectVariableBoolean
Object Fill Style 695 LONGINT VS:GetObjectVariableLongInt
Object Fill Type 696 INTEGER VS:GetObjectVariableInt
Object Use Local Mapping 697 BOOLEAN VS:GetObjectVariableBoolean
Object is Locked 700 TRUE or FALSE VS:GetObjectVariableBoolean
Format is Visible 900 TRUE or FALSE VS:GetObjectVariableBoolean
Text Is Linked To Record 680 TRUE or FALSE VS:GetObjectVariableBoolean
Text Repeating Tab 682 REAL (current units) VS:GetObjectVariableReal
Sweep Z Offset 401 REAL (current units) VS:GetObjectVariableReal
Saved View Saves View Orientation 450 TRUE or FALSE VS:GetObjectVariableBoolean
Saved View Saves Zoom and Pan 456 TRUE or FALSE VS:GetObjectVariableBoolean
Saved View Saves Page Location 451 TRUE or FALSE VS:GetObjectVariableBoolean
Saved View Saves Class Visibilities 452 TRUE or FALSE VS:GetObjectVariableBoolean
Saved View Saves Layer Visibilities 453 TRUE or FALSE VS:GetObjectVariableBoolean
Solid Has History 630 TRUE or FALSE VS:GetObjectVariableBoolean
Solid Scale X 631 REAL scale factor VS:GetObjectVariableReal
Solid Scale Y 632 REAL scale factor VS:GetObjectVariableReal
Solid Scale Z 633 REAL scale factor VS:GetObjectVariableReal
Bitmap Object Compression 532 0 (None) VS:GetObjectVariableLongInt
1 (JPEG) "
2 (PNG) "
3 (PNG Monochrome) "
Image Resource Compression 533 0 (None) VS:GetObjectVariableLongInt
1 (JPEG) "
2 (PNG) "
3 (PNG Monochrome) "
Set Design Layer Visibility in All Saved Views 454 -1 (Invisible) VS:GetObjectVariableInt
0 (Normal) "
2 (Grayed) "
3 (Don't Save) "
Set Class Visibility in All Saved Views 455 -1 (Invisible) VS:GetObjectVariableInt
0 (Normal) "
2 (Grayed) "
3 (Don't Save) "
Mark Object as Structural 702 True or False VS:GetObjectVariableBoolean
First Aux List Object 703 HANDLE VS:GetObjectVariableHandle
Custom Object Area 801 REAL (current units) VS:GetObjectVariableReal
Custom Object Perimeter 802 REAL (current units)
Sketch Style 1100 -2 No Sketch VS:GetObjectVariableLongInt
0 Default
Index of Sketch Style
Projection Type 1110 0 (Lambert Conic) 1 (UTM) VS:GetObjectVariableInt
Lat./Long. vs XY Flag 1111 True or False VS:GetObjectVariableBoolean
First Import Flag 1112 True or False VS:GetObjectVariableBoolean
New Layer/Class Flag 1113 True or False VS:GetObjectVariableBoolean
Model Space Scale 1114 REAL VS:GetObjectVariableReal
Georeference Point 1115 REAL VS:GetObjectVariableReal
Georeference Offset 1116 REAL VS:GetObjectVariableReal
Layer of First Import To Class 1117 LONGINT VS:GetObjectVariableLongInt
Thumbnail View 1152 INTEGER VS:GetObjectVariableInt
Thumbnail Render 1153 INTEGER VS:GetObjectVariableInt
RenderWorks Background Width 1154 REAL (current units) VS:GetObjectVariableReal
RenderWorks Background Height 1155 REAL (current units) VS:GetObjectVariableReal
Planar Object Is Screen Object 1160 TRUE or FALSE VS:GetObjectVariableBoolean

Appendix H - DoMenuTextByName Constants

Menu Commands

Menu Command Selector
Add Surface Add Surface
Align Objects Align Objects
Align to Grid Align to Grid
Vectorworks Preferences... Application Preferences
Arc Smoothing Arc Smoothing
Arrow Heads... Arrow Heads
Bezier Spline Smoothing Bezier Spline Smoothing
Classes... Classes
Clear Clear
Clip Surface Clip Surface
Close Close
Color Palette... Color Palette
Column... Column
Combine Into Surface Combine Into Surface
Compose Compose Curve
Convert Copy to Lines Convert Copy to Lines
Convert Copy to Polygons Convert Copy to Polygons
Convert to 3D Polys Convert to 3D Polys
Convert to Lines Convert to Lines
Convert to Mesh Convert to Mesh
Convert to NURBS Convert To NURBS
Convert to Polygons Convert to Polygons
Copy Copy
Create Layer Link... Create Layer Link
Create Plug-in... VectorScript Plug-in Editor
Create Report... Create Report
Create Symbol... Create Symbol
Cubic Spline Smoothing Cubic Spline Smoothing
Custom RenderWorks Options... Custom RW Options Chunk
Custom Selection... Custom Selection
Custom Tool/Attribute... Custom Tool/Attribute
Custom Visibility... Custom Visibility
Cut Cut
Cut 2D Section Cut 2D Section
Cut 3D Section Cut 3D Section
Dash Styles... Dash Styles
Decompose Decompose Curve
Deselect All Deselect All
Document Preferences Document Preferences
Duplicate Duplicate
Duplicate Array... Duplicate Array
Edit Constraints... Edit Constraints
Export Database... Export Database
Export DXF/DWG... Export DXFDWG
Export EPSF... Export EPSF
Export Image File... Export Image File
Export PICT... Export PICT
Export Simple VectorScript (3D Only)... Export Simple VectorScript (3D only)
Export VectorScript... Export Text Format
Export VRML... Export VRML Chunk
Export Worksheet... Export Worksheet
Extrude Extrude
Extrude... Extrude and Edit
Fit To Page Area Fit to Window
Flip Horizontal Flip Horizontal
Flip Vertical Flip Vertical
Floor... Floor
Format Text... Format Text
Hatch... Hatch
Import DXF/DWG... Import DXFDWG
Import EPSF... Import EPSF
Import Image File... Import Image File
Import PICT... Import PICT
Import PICT as Picture... Import PICT as Picture
Import 3DS (3D Only)... 3DS Import
Import VectorScript... Import Text Format
Import Worksheet... Import Worksheet
Intersect Surface Intersect Surface
Layer Scale... Layer Scale
Layers... Layers
Line Thickness... Line Thickness
Link Text To Record Link Text to Record
Lock Lock
lower case lower case
Move... Move
Move 3D... Move 3D
Move Working Plane Move Working Plane
Multiple Extrude Multiple Extrude
Multiple Extrude... Multiple Extrude and Edit
New... New
Next View Next View
No Smoothing No Smoothing
Normal Scale Normal Scale
Open... Open
Printer Setup... Page Setup
Paste Paste
Paste As Picture Paste As Picture
Paste In Place Paste In Place
Patterns... Patterns
Previous Selection Previous Selection
Previous Views Previous View
Print... Print
Engineering Properties... Properties
Quit Quit
Redo Redo
Revert To Saved Revert To Saved
Roof Face... Roof Face
Rotate... Rotate
Rotate 3D... Rotate 3D
Rotate 3D VIew... Rotate 3D View
Rotate Left 90° Rotate Left 90
Rotate Right 90° Rotate Right 90
Rotate Working Plane... Rotate Working Plane
Save Save
Save As... Save As
Save As Template... Save As Template
Save View Save View
Scale Objects... Scale Objects
Select All Select All
Send Backward Send Backward
Send Forward Send Forward
Send to Back Send to Back
Send to Front Send to Front
Set 3D View... Set 3D View
Set Grid... Set Grid
Set Layer Lighting Option Set Layer Lighting Options
Set Origin... Set Origin
Page Setup... Set Print Area
Set Size... Set Size
Shallow Symbol to Group Shallow Symbol to Group
Sweep Sweep
Sweep... Sweep and Edit
Symbol to Group Symbol to Group
Title Caps Title Caps
Trace Bitmap Trace Bitmap
Undo Undo
Units... Units
Unlock Unlock
Unrotate 3D Objects Unrotate 3D Objects
UPPER CASE UPPER CASE
Wall Framer... Wall Framer...
Workgroup References... Workgroup References

Menu Chunk Commands

Menu Command Selector
Create Batch Render Job... Batch Render Chunk
Start Batch Render...
Active Only Class Options
Gray Others
Gray/Snap Others
Show Others
Show/Snap Others
Show/Snap/Modify Others
Convert to Group Convert to Group Chunk
Export As MiniCAD 6 File... Export Previous File Version
Export As MiniCAD 7 File...
Export As Vectorworks 8 File...
4 Font Siz
6
7
8
9
10
12
14
18
20
24
28
36
48
72
96
144
Plain Font Style
Bold
Italic
Underline
Outline
Shadow
Group Group Chunk
Ungroup
Edit Group Group Navigation Chunk
Exit Group
Top Level
Make Guides Guides
Select Guides
Show Guides
Hide Guides
Delete All Guides
Join Join Chunk
Active Only Layer Options
Gray Others
Gray/Snap Others
Show Others
Show/Snap Others
Show/Snap/Modify Others
Hidden Line Line Render Chunk
Dashed Hidden Line
Line Render Options...
Sketch Sketch Chunk
Sketch Options...
OpenGL Options... OpenGL Options Chunk
OpenGL OpenGL Render Chunk
Set Perspective... Perspective Chunk
Narrow Perspective
Normal Perspective
Wide Perspective
Unshaded Polygon Polygon Render Chunk
Shaded Polygon
Shaded Polygon No Lines
Final Shaded Polygon
2D Plan Projection
Orthogonal
Perspective
Oblique Cavalier 45
Oblique Cavalier 30
Oblique Cabinet 45
Oblique Cabinet 30
Fast RenderWorks RenderWorks Render Chunk
Fast RenderWorks with Shadows
Final Quality RenderWorks
Custom RenderWorks
Custom RenderWorks Options...
Artistic RenderWorks
Artistic RenderWorks Options...
Add Solids Solid Operations
Subtract Solids...
Intersect Solids
Constraints Standard Palettes Chunk
Attributes
Object Info
Working Planes
Resources
Object Browser
Top/Plan Standard Views
Top
Front
Right
Bottom
Back
Left
Right Isometric
Left Isometric
Right Rear Iso
Left Rear Iso
Lower Right Iso
Lower Left Iso
Lower Right Rear
Lower Left Rear
Left Text Horizontal Alignment
Center
Right
Single Space Text Spacing
1-1/2 Space
Double Space
Other...
Top Text Vertical Alignment
Top Baseline
Center
Bottom Baseline
Bottom
Use Full Screen Use Full Screen Chunk
Wireframe Wireframe Render Chunk

Appendix I - Markers

Marker Styles and Constants

A marker style constant can be created by combining some of the basic elements listed below (Root Type, Base, Fill, Half Tick and Tail).

Root Type Constant
Arrow Marker
ConcavedCurvedArrowMarker 1
CircleMarker
DimSlashMarker
DimCrossMarker
LassoMarker
HexagonMarker
VShapedMarker
ConeShapedMarker
TaperedVShapedMarker
SShapedMarker 1
RectangleMarker 1
Base (Only meaningful for ArrowMarker and ConcaveCurvedArrowMarke) Constant
FlatBaseMarker
OpenBaseMarker 102
AngleBaseMarker 204
ArcBaseMarker 307
Fill Constant
LineColorMarker
WhiteFillMarker 12
NoFillMarker 25

Note

  1. NoFillMarker is the only valid setting for LassoMarker, DimSlashMarker, and DimCrossMarker
Tail (Meaningless for CircleMarker, DimCrossMarker, LassoMarker, HexagonMarker, ConeMarker, and RectangleMarker) Constant
TailMarker 32768
Half Tick (Meaningless for LassoMarker and ConeMarker) Constant
LeftHalfTickMarker 16384
RightHalfTickMarker 24576
Useful Composite Constants (Use these instead of Simpe Constants) Constant
OpenBaseNoFillMarker 128
NoFillLassoMarker 26
NoFillDimSlashMarker 25
NoFillDimSlashMarker 25
NoFillConeMarker 264
WhiteFillConeMarker 136
Examples Constan
style = 2176 <=> 0 + 2048 + 128 (ArrowMarker + AngleBaseMarker + WhiteFillMarker)
style = 16390 <=> 6 + 0 + 16384 (HexagonMarker + LineColorFillMarker + LeftHalfTickMarker

Marker Thicknes Basis and Unit

The marker thickness basis constant specifies the type and unit of the marker thickness to be set. A marker thickness basis constant is created by adding the thickness unit to the thickness basis. Note that the thickness value and unit are only meaningful for custom thickness.

Marker Thickness Basis Constant
Use Line Thickness 0
Use Dim Thickness 1
Custom Thickness 2
Marker Thickness Unit Constant
Mils 0
Points 16
Millimeters 32
Examples
thicknessBasis = 34 <=> 2 + 32 (Custom thickness in Millimeters)
thicknessBasis = 18 <=> 2 + 16 (Custom thickness in Points) 

Examples of

Marker Styles


Marker Style Example
0
256
1280
2
130
259
260
2048
17664
261
3073
1281
264
34048
16512
16384
9
135
32903
266
6
128