VS:ForEachMaterial: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:47, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Enumerate the materials in the current file.

PROCEDURE ForEachMaterial(
onlyUsed :BOOLEAN;
callback :PROCEDURE);
def vs.ForEachMaterial(onlyUsed, callback):
    return None

Parameters

onlyUsed BOOLEAN List only materials that are used in the current file.
callback PROCEDURE Callback to be executed for each material in the file, or for each material that is used, depending on the 'used' parameter.

Version

Availability: from Vectorworks 2021