VS:FlipHybMatrixObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add remark)
m (Transfer Orso to _c_)
 
(One intermediate revision by one other user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
inFlipSpecifier = 0 for flipH inFlipSpecifier = 1 for FlipV</desc>
inFlipSpecifier = 0 for flipH, inFlipSpecifier = 1 for FlipV</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 36: Line 36:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2015.12.09):  
([[User:ykostadinov|Yordan]] 2016.14.09):
From Vectorworks 2017 it flips object with any rotation.
 
([[User:CBM-c-|_c_]] 2015.12.09):  


Started from VWPluginLibraryRoutines.h VW12.
Started from VWPluginLibraryRoutines.h VW12.
Line 42: Line 45:
Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.
Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.


([[User:Orso.b.schmid|Orso]] 2008.05.11):  
([[User:CBM-c-|_c_]] 2008.05.11):  


Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.
Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.

Latest revision as of 05:10, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

inFlipSpecifier = 0 for flipH, inFlipSpecifier = 1 for FlipV

PROCEDURE FlipHybMatrixObj(
ioHybMatObj :HANDLE;
inFlipSpecifier :INTEGER);
def vs.FlipHybMatrixObj(ioHybMatObj, inFlipSpecifier):
    return None

Parameters

ioHybMatObj HANDLE
inFlipSpecifier INTEGER

Remarks

(Yordan 2016.14.09):

From Vectorworks 2017 it flips object with any rotation.

(_c_ 2015.12.09):

Started from VWPluginLibraryRoutines.h VW12.

Warning: it only works on symbols or plug-ins whose rotation is 0 or -180. Objects on drawing with any other rotation are ignored.

(_c_ 2008.05.11):

Flips hybrid objects: symbols and plug-ins. If the objects to flip are symbols you must coerce a redraw for the flip to be visible.

FlipHybMatrixObj(FSActLayer, 0); { FSActLayer is a symbol on drawing }
RedrawAll;

Version

Availability: from Vectorworks 2014