VS:FindObjAtPt GetObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns handle to the object in the find list created by [[VS:FindObjAtPt_Create]] call.
Get an object from the find iterator</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION FindObjAtPt_GetObj(finderID: LONGINT; objIndex: INTEGER) : HANDLE;
FUNCTION FindObjAtPt_GetObj(finderID:LONGINT; objIndex:INTEGER) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 25: Line 24:
finderID
finderID
LONGINT
LONGINT
Finder ID created by [[VS:FindObjAtPt_Create]].
 
</line>
</line>
<line>
<line>
objIndex
objIndex
INTEGER
INTEGER
Zero based index to an object in the found objects list. Should be less than the value returned from [[VS:FindObjAtPt GetCount]].
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
Returns handle to the specified object in the list.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
For example see Example of [[VS:FindObjAtPt Create]].
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
Related functions: [[VS:FindObjAtPt_Create]] | [[VS:FindObjAtPt_GetCount]] | [[VS:FindObjAtPt_GetObj]] | [[VS:FindObjAtPt_Delete]]
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|FindObjAtPt_GetObj]]
[[Category:VS Function Reference|FindObjAtPt_GetObj]]
[[Category:VS Function Reference:Utility|FindObjAtPt_GetObj]]
[[Category:VS Function Reference:Graphic Calculation|FindObjAtPt_GetObj]]

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get an object from the find iterator

FUNCTION FindObjAtPt_GetObj(
finderID :LONGINT;
objIndex :INTEGER) : HANDLE;
def vs.FindObjAtPt_GetObj(finderID, objIndex):
    return HANDLE

Parameters

finderID LONGINT
objIndex INTEGER

Version

Availability: from Vectorworks 2014