VS:FindAttribute

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the element path of the specified attribute.

FUNCTION FindAttribute(
XMLHandle :LONGINT;
startElementPath :STRING;
searchAttribute :STRING;
VAR foundPath :STRING;
VAR attributeValue :STRING) :INTEGER;
def vs.FindAttribute(XMLHandle, startElementPath, searchAttribute):
    return (INTEGER, foundPath, attributeValue)

Parameters

XMLHandle LONGINT
startElementPath STRING
searchAttribute STRING
foundPath STRING Output parameter.
attributeValue STRING Output parameter.

Version

Availability: from All Versions

This is drop-in function.