VS:FindAttribute: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the element path of the specified attribute.

FUNCTION FindAttribute(
XMLHandle :LONGINT;
startElementPath :STRING;
searchAttribute :STRING;
VAR foundPath :STRING;
VAR attributeValue :STRING) :INTEGER;
def vs.FindAttribute(XMLHandle, startElementPath, searchAttribute):
    return (INTEGER, foundPath, attributeValue)

Parameters

XMLHandle LONGINT
startElementPath STRING
searchAttribute STRING
foundPath STRING Output parameter.
attributeValue STRING Output parameter.

Version

Availability: from All Versions

This is drop-in function.