VS:FillPat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure FillPat sets the active fill pattern for the document. Any objects created after a calling this procedure will use the specified fill pattern.

Fill patterns and their associated constants can be found in the VectorScript Appendix.

PROCEDURE FillPat(
patNumber :LONGINT);
def vs.FillPat(patNumber):
    return None

Parameters

patNumber LONGINT Index of fill pattern to be set as document default.

Example

VectorScript

Rect(0,0,2,2);
FillPat(21);
Rect(2,2,4,4);

Python

vs.Rect(0,0,2,2)
vs.FillPat(21)
vs.Rect(2,2,4,4)

Version

Availability: from All Versions