VS:FillFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(update remarks)
Line 31: Line 31:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>This routine will also accept a color index, see [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Index Pitfalls, Colors]</remark>
<remark>
[[User:Orso.b.schmid| Orso]]: This routine will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with [[VS:RGBToColorIndex]]. See remarks under [[VS:SetPenFore]] for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: [http://www.vectorlab.info/index.php?title=Index_pitfalls#Colors Color Index].
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 03:40, 19 May 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure FillFore sets the active fill foreground color setting for the document. RGB values are in the range of 0~65535.

PROCEDURE FillFore(
color :LONGINT);
def vs.FillFore(color):
    return None

Parameters

color LONGINT RGB color value to set as active fill foreground color.

Remarks

Orso: This routine will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Example

VectorScript

FillFore(65535,0,39321); { using RGB values }
FillFore(7); { using Color Index values }

Python

vs.FillFore(65535,0,39321) #{ using RGB values }
vs.FillFore(7) #{ using Color Index values }

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]