VS:FillBack

From Vectorworks Developer
Revision as of 05:11, 19 May 2015 by CBM-c- (talk | contribs) (correct python brakets, add color index access using routine (more secure))
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure FillBack sets the active fill background color setting for the document. RGB values are in the range of 0~65535.

PROCEDURE FillBack(
color :LONGINT);
def vs.FillBack(color):
    return None

Parameters

color LONGINT RGB color value to set as active fill background color.

Remarks

Orso: This routine will also accept a single INTEGER Color Palette Index value in lieu of three LONGINT RGB values for the COLOR parameter. The Color index can be obtained with VS:RGBToColorIndex. See remarks under VS:SetPenFore for more infos. On Vectorlab there is a list of all color routines accepting multiple variable type, see: Color Index.

Example

VectorScript

FillBack(65535, 0, 39321); { using RGB values }

colorIndex := RGBToColorIndex(65535, 0, 39321);
FillBack(colorIndex); { using Color Index values }

Python

vs.FillBack((65535, 0, 39321)) # using RGB values

colorIndex = vs.RGBToColorIndex(65535, 0, 39321)
vs.FillBack(colorIndex) # using Color Index values

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]