VS:Field: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Obsolete.
<b>Obsolete. Use [[VS:SetRField| SetRField]] for new scripts.</b>
</desc>
</desc>


Line 48: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Obsolete function maintained for compatibility with old scripts. Use &quot;SetRField&quot; for new scripts.  See &quot;SetRField&quot;.
Obsolete function maintained for compatibility with old scripts. Use [[VS:SetRField| SetRField]] for new scripts.


Update the RecordNode attached to object &quot;h&quot; by setting the field &quot;s2&quot; of format &quot;s1&quot; to the value &quot;s3&quot;.  The object is not redrawn immediately, so don't call this for a symbol which uses the &quot;link text to record&quot; feature.
[sd 9/14/98] Update the RecordNode attached to object "h" by setting the field "s2" of format "s1" to the value "s3".  The object is not redrawn immediately, so don't call this for a symbol which uses the "link text to record" feature.
 
</remark>
[sd 9/14/98]</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 62: Line 61:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from All Versions. Obsolete from VW 9.


</version>
</version>

Latest revision as of 20:38, 11 November 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Obsolete. Use SetRField for new scripts.

PROCEDURE Field(
h :HANDLE;
s1 :STRING;
s2 :STRING;
s3 :STRING);
def vs.Field(h, s1, s2, s3):
    return None

Parameters

h HANDLE
s1 STRING
s2 STRING
s3 STRING

Remarks

Obsolete function maintained for compatibility with old scripts. Use SetRField for new scripts.

[sd 9/14/98] Update the RecordNode attached to object "h" by setting the field "s2" of format "s1" to the value "s3". The object is not redrawn immediately, so don't call this for a symbol which uses the "link text to record" feature.

Version

Availability: from All Versions. Obsolete from VW 9.

See Also

VS Functions:

VS:SetRField

VS Functions: [[VS:SetRField]]