VS:FPenPatN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add example and remark)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 21: Line 21:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): [[VS:FPenPatN]] returns the name list index of the active dash style, while the older routine [[VS:FPenPat]] will return the dash style index. They are not the same.
[[User:CBM-c-|_c_]] (2016.02.29): [[VS:FPenPatN]] returns the name list index of the active dash style, while the older routine [[VS:FPenPat]] will return the dash style index. They are not the same.


<code lang='vs'>
<code lang='vs'>
{ compare the two different indexes: }
{ compare the two different indexes: }
FPenPat; { returns the dash style list index corresponding to the active dash style }
indx := FPenPat; { returns the dash style list index corresponding to the active dash style }
FPenPatN; { returns the name list index corresponding to the active dash style }
indx := FPenPatN; { returns the name list index corresponding to the active dash style }
</code>
</code>
</remark>
</remark>

Latest revision as of 06:45, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function FPenPatN returns the active pen pattern setting.

FUNCTION FPenPatN : LONGINT;
def vs.FPenPatN():
    return LONGINT

Remarks

_c_ (2016.02.29): VS:FPenPatN returns the name list index of the active dash style, while the older routine VS:FPenPat will return the dash style index. They are not the same.

{ compare the two different indexes: }
indx := FPenPat; { returns the dash style list index corresponding to the active dash style }
indx := FPenPatN; { returns the name list index corresponding to the active dash style }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:PenPatN

VS Functions: [[VS:PenPatN]]