VS:ExtrudeAlongPath/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

3Dパス図形を作成します。輪郭をパスに沿って引き延ばした図形が作成されます。

パスの引数はNurbs曲線(図形タイプ111)である必要があります。輪郭は次のいずれかの図形です:Nurbs曲線、多角形、曲線、円弧、四角形、隅の丸い四角形、直線、楕円。

FUNCTION ExtrudeAlongPath(
pathHandle :HANDLE;
profileHandle :HANDLE) : HANDLE;
def vs.ExtrudeAlongPath(pathHandle, profileHandle):
    return HANDLE

Parameters

pathHandle HANDLE パスのハンドル(NURBS曲線)
profileHandle HANDLE 輪郭のハンドル

Return Value

成功した場合は汎用ソリッドへのハンドルが返されます。そうでない場合はNILが返されます。

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateExtrudeAlongPath

VS Functions: [[VS:CreateExtrudeAlongPath]]