VS:ExtrudeAlongPath

From Vectorworks Developer
Revision as of 06:03, 13 May 2018 by CBM-c- (talk | contribs) (add remark about generic solid)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new path extrude object in the document. The profile defines the shape of the cross-section, and is extruded along the path to generate the resulting object.


The path argument must be a handle to a NURBS Curve object (type 111). The profile argument must be a handle to an object of one of the following types: NURBS Curve, Polygon, Polyline, Arc, Rectangle, Rounded Rectangle, Line, Oval.

FUNCTION ExtrudeAlongPath(
pathHandle :HANDLE;
profileHandle :HANDLE) : HANDLE;
def vs.ExtrudeAlongPath(pathHandle, profileHandle):
    return HANDLE

Parameters

pathHandle HANDLE Handle to the path object.
profileHandle HANDLE Handle to the profile object.

Return Value

Returns a generic solid HANDLE to the new path extrude if successful, otherwise returns NIL.

Remarks

Orso, 2018.05.13: The generated extrusion is a Generic Solid and won't take the active class attributes, while CreateExtrudeAlongPath will create a number of NURBS curves with class attributes, but they won't section properly in Section Viewports without stitch and trim, since they don't generate a fill. Tested in Pio: OK.



The generic solid can not be edited

The following objects are supported as profile objects:

Line 2
Box 3
Oval 4
Polygon 5
Arc 6
Freehand 8
R Rect 13
Polyline 21
3D Poly 25
NURBS Curve 111


Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateExtrudeAlongPath

VS Functions: [[VS:CreateExtrudeAlongPath]]