VS:ExtrudeAlongPath

From Vectorworks Developer
Revision as of 17:34, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new path extrude object in the document. The profile defines the shape of the cross-section, and is extruded along the path to generate the resulting object.


The path argument must be a handle to a NURBS Curve object (type 111). The profile argument must be a handle to an object of one of the following types: NURBS Curve, Polygon, Polyline, Arc, Rectangle, Rounded Rectangle, Line, Oval.

FUNCTION ExtrudeAlongPath(
pathHandle :HANDLE;
profileHandle :HANDLE) : HANDLE;
def vs.ExtrudeAlongPath(pathHandle, profileHandle):
    return HANDLE

Parameters

pathHandle HANDLE Handle to the path object.
profileHandle HANDLE Handle to the profile object.

Return Value

Returns a generic solid HANDLE to the new path extrude if successful, otherwise returns NIL.

Remarks

The generic solid can not be edited


The following objects are supported as profile objects:

Line 2
Box 3
Oval 4
Polygon 5
Arc 6
Freehand 8
R Rect 13
Polyline 21
3D Poly 25
NURBS Curve 111


Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateExtrudeAlongPath

VS Functions: [[VS:CreateExtrudeAlongPath]]