VS:ExtendNurbsSurface

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Extends a surface by a given distance at the start or the end of the U direction or V direction.

FUNCTION ExtendNurbsSurface(
surfaceHandle :HANDLE;
distance :REAL;
bStart :BOOLEAN;
bLinear :BOOLEAN;
bUDir :BOOLEAN) : HANDLE;
def vs.ExtendNurbsSurface(surfaceHandle, distance, bStart, bLinear, bUDir):
    return HANDLE

Parameters

surfaceHandle HANDLE Handle to a NURBS surface.
distance REAL Distance to extend the surface.
bStart BOOLEAN True to extend from the beginning, false to extend from the end.
bLinear BOOLEAN True for linear, false to match curvature of existing surface.
bUDir BOOLEAN True extends the surface in the u parametric

Return Value

Returns a handle to the extended surface

Version

Availability: from VectorWorks10.0