VS:ExtendNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Extends a curve by a given distance at the start or the end. The extension can either be linear or can match the curvature of the existing end.

FUNCTION ExtendNurbsCurve(
curveHandle :HANDLE;
distance :REAL;
bStart :BOOLEAN;
bLinear :BOOLEAN) : HANDLE;
def vs.ExtendNurbsCurve(curveHandle, distance, bStart, bLinear):
    return HANDLE

Parameters

curveHandle HANDLE Handle to a NURBS curve
distance REAL Distance to extend the curve
bStart BOOLEAN True to extend the curve at the beginning, false to extend it at the end.
bLinear BOOLEAN True for linear, false to match curvature of existing end.

Return Value

Returns a handle to the extended curve.

Version

Availability: from VectorWorks10.0