VS:ExportSTL

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Export the objects into a STL file.

FUNCTION ExportSTL(
filePath :STRING;
exportBinary :BOOLEAN;
percentTess :REAL;
exportObjectsOptions :INTEGER) : BOOLEAN;
def vs.ExportSTL(filePath, exportBinary, percentTess, exportObjectsOptions):
    return BOOLEAN

Parameters

filePath STRING Output file path.
exportBinary BOOLEAN binary or ASCII output
percentTess REAL tessellation resolution -- from 0 to 100 0 -- low, 100 --high
exportObjectsOptions INTEGER 0 -- export visilble objects selected 1 -- export visible objects in activeLayer 2 -- export visible objects in all Layer

Return Value

Return TRUE if successful.

Version

Availability: from Vectorworks 2016