VS:ExportSTL: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 50: Line 50:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
STL is a native file format to the stereolithography CAD software created by 3D Systems.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 11:56, 19 November 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Export the objects into a STL file.

FUNCTION ExportSTL(
filePath :STRING;
exportBinary :BOOLEAN;
percentTess :REAL;
exportObjectsOptions :INTEGER) : BOOLEAN;
def vs.ExportSTL(filePath, exportBinary, percentTess, exportObjectsOptions):
    return BOOLEAN

Parameters

filePath STRING Output file path.
exportBinary BOOLEAN binary or ASCII output
percentTess REAL tessellation resolution -- from 0 to 100 0 -- low, 100 --high
exportObjectsOptions INTEGER 0 -- export visilble objects selected 1 -- export visible objects in activeLayer 2 -- export visible objects in all Layer

Return Value

Return TRUE if successful.

Remarks

STL is a native file format to the stereolithography CAD software created by 3D Systems.

Version

Availability: from Vectorworks 2016