VS:EvaluateNurbsSurfacePointAndNormal

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Determines the point and normal on the NURBS surface at the given u/v value.

FUNCTION EvaluateNurbsSurfacePointAndNormal(
surfaceHandle :HANDLE;
u :REAL;
v :REAL;
VAR pointX,pointY,pointZ :REAL;
VAR normalX,normalY,normalZ :REAL) : BOOLEAN;
def vs.EvaluateNurbsSurfacePointAndNormal(surfaceHandle, u, v):
    return (BOOLEAN, point, normal)

Parameters

surfaceHandle HANDLE Handle to NURBS surface being evaluated
u REAL parameter value of the point on the surface being evaluated
v REAL parameter value of the point on the surface being evaluated
point REAL Coordinate of the point on the surface
normal REAL normal vector of the surface computed at the point

Version

Availability: from VectorWorks10.0