VS:EqPt

From Vectorworks Developer
Revision as of 04:30, 22 January 2022 by CBM-c- (talk | contribs) (fix)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns TRUE if the 2D points are equal within the tolerance.

FUNCTION EqPt(
pt1 :VECTOR;
pt2 :VECTOR;
tolerance :REAL) : BOOLEAN;
def vs.EqPt(pt1, pt2, tolerance):
    return BOOLEAN

Parameters

pt1 VECTOR
pt2 VECTOR
tolerance REAL

Remarks

(_c_, 2022.01.21) Tolerance must be <> 0. By a tolerance of 0 EqPt will always return false. In Python, contrary to most Pascal-derived vectorial routines, EqPt accepts also a bidimensional tuple without returning gibberish: the third item will always be ignored. So this is a 2D-only routine.

Example

Vectorscript

PROCEDURE Example;
VAR
    v1, v2 : VECTOR;
BEGIN
    v1.x := 12; v1.y := 1;
    v2.x := 12; v2.y := 1;
    Message(Concat( EqPt(v1, v2, 0.1) ));
END;
Run(Example);

Python

v1 = (12, 1, 999) # z vals in 3-dimensional tuples will be ignored
v2 = (12, 1, 0)
vs.Message( str(vs.EqPt(v1, v2, 0.1)) )

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS Functions:
  • [[VS:EqualPt]]
  • [[VS:EqPt2D]]
  • [[VS:EqPt3D]]