VS:Energos Thirdparty Support

From Vectorworks Developer
Revision as of 13:12, 18 September 2015 by Gkutleva (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Energy Analysis is a plugin which uses data from objects in the Vectorworks document to calculate energy performance of a 3D building. It provides the user with a graphical and numerical feedback. It provides also a set of functions to give the ability to include third-party objects into energy calculations.

This document explains how to use the set of script functions to include third-party objects to the energy calculation.

The set of energy script functions are grouped in several categories.

Unit conversion support

Energy analysis module uses distinct units from documents units for calculation. This group of functions supports the conversion between the SI unit system and the local unit system. The local unit system is defined in an XML file (EnergyUnits.xml), located in default libraries. In the table below are shown the units used by the energy analysis module. Column “Unit type” shows the INTEGER representations of unit type used by script functions.

Objects support (for space, window/door, wall, slab and roof)

There are several objects which are included in energy analysis calculations. They are spaces, windows, doors, walls, slabs and roofs. All building elements use the functions described below to get/set/save energy data in objects and that happens with support from energy analysis plugin. Energy analysis plugin attaches energy data node to each object who is involved into energy calculation. All the functions which set data are mandatory. Otherwise the energy analysis module won’t handle the object properly or will exclude it from calculation.

Object components support (for wall, slab and roof only)

Wall, slab and roof object have components. The functions below manage the components.

User interface support

Objects which use energy data need user interface changes. Except the popups and edit fields some of the objcts have external system data and it is magaged via popups.

Space object does not have special controls.

Window/door preference dialog must have popups for frame, glazing and shading settings. They are provided by the energy analysis module. The only thing which should be done is to specify the popup as energy popup. Also event hander should use energy plugin to process the event.

Wall, roof and slab have boundary type popup.