VS:EndXtrd

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure EndXtrd completes the definition of an extrude object within a VectorWorks document. On calling EndXtrd, the object is created in the document from the preceding object creation calls.

It is recommended to call ResetOrientation3D after 3D object creations in order to ensure that the new 3D objects will draw properly.

PROCEDURE EndXtrd;
def vs.EndXtrd():
    return None

Example

VectorScript

PROCEDURE Example;
VAR
h1, h2, h3 :HANDLE;
int :INTEGER;
BEGIN
DSelectAll; BeginXtrd(0, 1); CallTool(-203); h1 := FSActLayer; EndXtrd;
DSelectAll; BeginXtrd(0, 1); CallTool(-203); h2 := FSActLayer; EndXtrd;
int := AddSolid(h1, h2, h3);
END;
RUN(Example);

Python


BeginXtrd(0',4');
Rect(-1 61/64",125/128",-1 119/256",-375/512");
Rect(-1 113/512",1 113/512",-375/512",-125/256");
Rect(-125/256",125/128",0',-375/512");
Rect(125/128",125/128",1 119/256",-375/512");
Rect(1 25/512",1 113/512",375/512",-125/256");
Rect(1 363/512",1 113/512",2 101/512",-125/256");
EndXtrd;

Python


Version

Availability: from All Versions