VS:EndSweep

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure EndSweep completes the definition of a sweep object within a VectorWorks document. On calling EndSweep, the object is created in the document from the preceding object creation calls.

It is recommended to call ResetOrientation3D after 3D object creations in order to ensure that the new 3D objects will draw properly.

PROCEDURE EndSweep;
def vs.EndSweep():
    return None

Example

VectorScript

BeginSweep(#0,#360,#10,0');
Poly(3 1/4",-1/2",3 1/4",-1",2 3/4",-1",
2 1/4",-1/2",2 1/4",1",1 3/4",1 1/2",
-1 3/4",1 1/2",-2 1/4",1",-2 1/4",-1/2",
-2 3/4",-1",-3 1/4",-1",-3 1/4",-1/2",
-2 3/4",0",-2 3/4",1 1/2",-2 1/4",2",
2 1/4",2",2 3/4",1 1/2",2 3/4",0");
EndSweep;

Python

vs.BeginSweep(0,360,10,0)
vs.Poly(3 + 1/4,-1/2,3 + 1/4,-1,2 + 3/4,-1,
2 + 1/4,-1/2,2 + 1/4,1,1 + 3/4,1 + 1/2,
-1 + 3/4,1 + 1/2,-2 + 1/4,1,-2 + 1/4,-1/2,
-2 + 3/4,-1,-3 + 1/4,-1,-3 + 1/4,-1/2,
-2 + 3/4,0,-2 + 3/4,1 + 1/2,-2 + 1/4,2,
2 + 1/4,2,2 + 3/4,1 + 1/2,2 + 3/4,0)
vs.EndSweep()

Version

Availability: from All Versions