VS:EndContext

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use this function in conjuction with BeginContext to have VW automatically accept or reject any changes that were made during the Begin/End block.

PROCEDURE EndContext(
acceptOrReject :INTEGER);
def vs.EndContext(acceptOrReject):
    return None

Parameters

acceptOrReject INTEGER Specify 0 to reject changes or 1 to accept changes

Remarks

If you do not use this construct and you create a temporary plug-in object that itself creates a new class, the new class will remain even after you delete the temporary plug-in object.

Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:BeginContext

VS Functions: [[VS:BeginContext]]