VS:EnableParameter

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

For plug-in objects, this procedure sets whether or not the specified parameter is enabled on the Object Info Palette. This routine is used inside plug-in object regeneration scripts to set their parameter enable state. This state is an object instance property.

PROCEDURE EnableParameter(
inPlugin :HANDLE;
inParameterName :STRING;
inSetEnabled :BOOLEAN);
def vs.EnableParameter(inPlugin, inParameterName, inSetEnabled):
    return None

Parameters

inPlugin HANDLE Handle to the currently executing plug-in object.
inParameterName STRING Name of parameter, as it appears in the plug-in editor's parameter list.
inSetEnabled BOOLEAN Enabling flag.

Version

Availability: from VectorWorks10.0