VS:EditRenderWorksPrefs: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This procedure displays the renderworks Custom rendering options dialog. The upateRendering boolean returns false if the user presses cancel in the rendering preferences dialog and True if the user presses OK.
Allows the user to edit RenderWorks renderer preferences and stores them in the current drawing.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE EditRenderWorksPrefs(VAR updateRendering :BOOLEAN);
PROCEDURE EditRenderWorksPrefs(VAR updateRendering:BOOLEAN);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 25: Line 24:
updateRendering
updateRendering
BOOLEAN
BOOLEAN
Output parameter.
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 17:37, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Allows the user to edit RenderWorks renderer preferences and stores them in the current drawing.

PROCEDURE EditRenderWorksPrefs(
VAR updateRendering :BOOLEAN);
def vs.EditRenderWorksPrefs():
    return updateRendering

Parameters

updateRendering BOOLEAN

Version

Availability: from Vectorworks 2014