VS:EditOpenGLPrefs: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This procedure displays the OpenGL rendering preferences dialog for the user to change rendering settings. The UpdateRendering boolean returns True if the user Clicks the OK button in the dialog and false if they click Cancel.
Allows the user to edit OpenGL renderer preferences and stores them in the current drawing.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE EditOpenGLPrefs(VAR updateRendering :BOOLEAN);
PROCEDURE EditOpenGLPrefs(VAR updateRendering:BOOLEAN);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 25: Line 24:
updateRendering
updateRendering
BOOLEAN
BOOLEAN
Output parameter.
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:37, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Allows the user to edit OpenGL renderer preferences and stores them in the current drawing.

PROCEDURE EditOpenGLPrefs(
VAR updateRendering :BOOLEAN);
def vs.EditOpenGLPrefs():
    return updateRendering

Parameters

updateRendering BOOLEAN

Version

Availability: from Vectorworks 2014