VS:EditCriteriaWithUI

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Edit a criteria string with Edit Criteria Dialog.

FUNCTION EditCriteriaWithUI(
VAR criteria :DYNARRAY[] of CHAR) : INTEGER;
def vs.EditCriteriaWithUI(criteria):
    return (INTEGER, criteria)

Parameters

criteria DYNARRAY[] of CHAR Pass in a criteria to be edited, and output the modified criteria if the function result is TRUE.

Return Value

The funtion returns the following values:

0 - failed. The input criteria is incorrect.
1 - The edit was OK
2 - The edit was Cancel

Version

Availability: from Vectorworks 2014