VS:EOLN

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function EOLN returns TRUE if the file pointer of an open text file has reached a carriage return within the file. Parameter fileName specifies a text file which is open for reading or writing.

FUNCTION EOLN(
fileName :STRING) : BOOLEAN;
def vs.EOLN(fileName):
    return BOOLEAN

Parameters

fileName STRING Name of file.

Example

VectorScript

BEGIN
  Open('MyData');
  WHILE NOT EOLN('MyData') DO BEGIN
    Read(a,b,c,d);
  END;

  Close('MyData');
END;

Python


Version

Availability: from All Versions