VS:EA DataAccCompGet

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets object component data.

PROCEDURE EA_DataAccCompGet(
acc :INTEGER;
VAR componentIndex :INTEGER;
VAR outInclude :BOOLEAN;
VAR outLambda :REAL;
VAR outThickness :REAL);
def vs.EA_DataAccCompGet(acc):
    return (componentIndex, outInclude, outLambda, outThickness)

Parameters

acc INTEGER
componentIndex INTEGER
outInclude BOOLEAN
outLambda REAL
outThickness REAL

Remarks

(_c_, 2022.04.14):

Python only: EA_DataAccCompGet can't be used for VW before 2022 SP4, the index returned is gibberish.

An extensive example about the Energos access can be found under VS:EA DataAccCreate

Version

Availability: from Vectorworks 2016