VS:EA DataAccCompGet

From Vectorworks Developer
Revision as of 05:39, 14 April 2022 by CBM-c- (talk | contribs) (add note about python access for this call)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets object component data.

PROCEDURE EA_DataAccCompGet(
acc :INTEGER;
VAR componentIndex :INTEGER;
VAR outInclude :BOOLEAN;
VAR outLambda :REAL;
VAR outThickness :REAL);
def vs.EA_DataAccCompGet(acc):
    return (componentIndex, outInclude, outLambda, outThickness)

Parameters

acc INTEGER
componentIndex INTEGER
outInclude BOOLEAN
outLambda REAL
outThickness REAL

Remarks

(_c_, 2022.04.14):

Python only: EA_DataAccCompGet can't be used for VW before 2022 SP4, the index returned is gibberish.

An extensive example about the Energos access can be found under VS:EA DataAccCreate

Version

Availability: from Vectorworks 2016