VS:Duplicate: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 1: Line 1:
{{LocationMain|category=LocationVS|specific=}}
{{LocationMain|category=LocationVS|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>

Latest revision as of 15:40, 28 February 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Duplicate copies the currently selected objects and moves them the specified offset distance.

PROCEDURE Duplicate(
offset :REAL);
def vs.Duplicate(offset):
    return None

Parameters

offset REAL Offset value.

Remarks

If user has "Offset Duplications" turned off, Duplicate ignores the x/y.

Example

VectorScript

Rect(0,1,1,0);
Duplicate(2,0);
{duplicates the rectangle 2 units right of the original}

Python

vs.Rect(0,1,1,0)
vs.Duplicate(2,0)
#{duplicates the rectangle 2 units right of the original}

Version

Availability: from All Versions