VS:DoubleFixedTolerance

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure DoubleFixedTolerance is used with dimensioning procedures to define a tolerance for the most recently created dimension object.

PROCEDURE DoubleFixedTolerance(
showVal :BOOLEAN;
boxText :BOOLEAN;
leader :STRING;
trailer :STRING;
topStr :STRING;
botStr :STRING);
def vs.DoubleFixedTolerance(showVal, boxText, leader, trailer, topStr, botStr):
    return None

Parameters

showVal BOOLEAN Dimension text display flag.
boxText BOOLEAN Boxed text display flag.
leader STRING Dimension leader text string.
trailer STRING Dimension trailer text string.
topStr STRING Tolerance value text string.
botStr STRING Tolerance value text string.

Example

VectorScript

LinearDim(-2",2",1",2",-3",0,771,771,0.75);
DoubleFixedTolerance(TRUE,FALSE,'','','yes','no');
{defines a dimension with a double fixed tolerance}

Python

vs.LinearDim(-2,2,1,2,-3,0,771,771,0.75)
vs.DoubleFixedTolerance(True,False,'','','yes','no')
#{defines a dimension with a double fixed tolerance}

Version

Availability: from MiniCAD4.0