VS:DialogEvent

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Monitors user activity within a dialog; when an item is selected, the numeric identifier of the item is returned.

PROCEDURE DialogEvent(
VAR item :INTEGER);
def vs.DialogEvent():
    return item

Parameters

item INTEGER Returns item selected in dialog event.

Remarks

Note: deprecated from VW 9: see RunLayoutDialog.

Example

VectorScript

REPEAT
DialogEvent(Item);

CASE Item OF
{- OK button case -}
1:Done:=TRUE;
{- Cancel button case -}
2:Stop:=TRUE;
OTHERWISE SysBeep;
END;
UNTIL Done;

Python


Version

Availability: from All Versions. Deprecated from VW 9+.