VS:DetailGraphicOptDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:29, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This brings up the Graphic Options dialog for Detail-Callout Marker and Detail Callout objects.

FUNCTION DetailGraphicOptDlg(
VAR Marker :STRING;
VAR ShoulderLength :REAL;
VAR TagPosIndex :INTEGER;
VAR LeaderType :LONGINT;
VAR LeaderThick :INTEGER) : BOOLEAN;
def vs.DetailGraphicOptDlg(Marker, ShoulderLength, TagPosIndex, LeaderType, LeaderThick):
    return (BOOLEAN, Marker, ShoulderLength, TagPosIndex, LeaderType, LeaderThick)

Parameters

Marker STRING The name of the selected Marker symbol.
ShoulderLength REAL The shoulder length for the detail callout object.
TagPosIndex INTEGER The index of the selected Tag Position.
LeaderType LONGINT The linetype for the leader lines.
LeaderThick INTEGER The line thickness for the leader line.

Return Value

Whether the user clicked on the OK button.

Version

Availability: from Vectorworks 2013