VS:DeleteTextureSpace

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function DeleteTextureSpace deletes the texture space attached to the referenced object or object part.

PROCEDURE DeleteTextureSpace(
obj :HANDLE;
partID :INTEGER);
def vs.DeleteTextureSpace(obj, partID):
    return None

Parameters

obj HANDLE Handle to object.
partID INTEGER Part ID (pass 1 for non-supporting objects).

Remarks

Removes the texture space from this object. To render textures correctly, an object must have both a non-zero texture ref and a texture space attached. The reverse of this means that the texture ref for the object should be set to zero when this function is called.

Version

Availability: from VectorWorks8.0