VS:DeleteTextureSpace

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function DeleteTextureSpace deletes the texture space attached to the referenced object or object part.

PROCEDURE DeleteTextureSpace(
obj :HANDLE;
partID :INTEGER);
def vs.DeleteTextureSpace(obj, partID):
    return None

Parameters

obj HANDLE Handle to object.
partID INTEGER Part ID (pass 1 for non-supporting objects).

Remarks

Removes the texture space from this object. To render textures correctly, an object must have both a non-zero texture ref and a texture space attached. The reverse of this means that the texture ref for the object should be set to zero when this function is called.

Version

Availability: from VectorWorks8.0