VS:DeleteSymbolDefinition

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure DeleteSymbolDefinition deletes the referenced symbol definition from the document. If bCompletely is TRUE, all corresponding symbol instances will be deleted completely; otherwise, the symbol instances will be replaced with loci.

PROCEDURE DeleteSymbolDefinition(
hSymDef :HANDLE;
bCompletely :BOOLEAN);
def vs.DeleteSymbolDefinition(hSymDef, bCompletely):
    return None

Parameters

hSymDef HANDLE Handle to the symbol definition.
bCompletely BOOLEAN Determines whether to replace the corresponding symbol instances with loci or delete the instances completely.

Version

Availability: from Vectorworks 2011