VS:DeleteLevelTemplate: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (there was a copy/paste error: example said "DeleteLayerTemplate" instead of "DeleteLevelTemplate")
 
(One intermediate revision by one other user not shown)
Line 46: Line 46:
BEGIN
BEGIN


success := DeleteStoryTemplate(3);</code>
success := DeleteLevelTemplate(3);</code>
</sample>
</sample>



Latest revision as of 08:33, 14 April 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes the nth Story Level Template from the current file. For example, if 3 is passed in, it will delete the 3rd Story Level Template in the file.

FUNCTION DeleteLevelTemplate(
index :INTEGER) : BOOLEAN;
def vs.DeleteLevelTemplate(index):
    return BOOLEAN

Parameters

index INTEGER The index of the Story Level Template to be deleted.

Return Value

Whether the Story Level Template at 'index' was found and deleted successfully.

Example

VAR

success:BOOLEAN;

BEGIN

success := DeleteLevelTemplate(3);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetNumStoryTemplates | VS:GetLevelTemplateName | VS:SetLevelTemplateName | VS:CreateLevelTemplate | VS:GetLevelTemplateInfo

VS Functions:

[[VS:GetNumStoryTemplates]] | [[VS:GetLevelTemplateName]] | [[VS:SetLevelTemplateName]] | [[VS:CreateLevelTemplate]]

| [[VS:GetLevelTemplateInfo]]