VS:DeleteComponent: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(shorten 'object' (reserved word), add remark about roof styles on VW 2016)
(One intermediate revision by one other user not shown)
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION DeleteComponent(object:HANDLE; componentIndex:INTEGER) : BOOLEAN;
FUNCTION DeleteComponent(obj:HANDLE; componentIndex:INTEGER) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.DeleteComponent(object, componentIndex):
def vs.DeleteComponent(obj, componentIndex):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 23: Line 23:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>[[User:Orso.b.schmid| Orso]]: (2016.02.03):  Supports also Roof and Roof Styles components from VW 2016.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 49: Line 50:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.0
Availability: from VectorWorks 12.0


</version>
</version>

Revision as of 06:19, 3 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes a component in an object.

FUNCTION DeleteComponent(
obj :HANDLE;
componentIndex :INTEGER) : BOOLEAN;
def vs.DeleteComponent(obj, componentIndex):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex INTEGER The index of the component to delete.

Remarks

Orso: (2016.02.03): Supports also Roof and Roof Styles components from VW 2016.

Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS:InsertNewComponent

VS Functions: [[VS:InsertNewComponent]]